summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRussell Greene2017-05-19 22:42:25 -0600
committerRussell Greene2017-05-19 22:42:25 -0600
commit4205eae3f83d73bc957efcafd2e8244c326c33dc (patch)
tree95ccd813c3c37dbec0ea65240081b4b5b12be675
downloadaur-chigraph-gui.tar.gz
Initial Commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93f5221fff8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = chigraph-gui
+ pkgdesc = The GUI for chigraph, a visual programming language
+ pkgver = 1.0.0a
+ pkgrel = 1
+ url = https://github.com/chigraph/chigraph
+ arch = i686
+ arch = x86_64
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ makedepends = tar
+ makedepends = gzip
+ depends = chigraph
+ depends = kxmlgui
+ depends = ktexteditor
+ conflicts = chigraph-gui-git
+ source = https://github.com/russelltg/nodeeditor/archive/v1.0.0a.tar.gz:nodeeditor-1.0.0a.tar.gz
+ source = https://github.com/chigraph/chigraph-gui/archive/v1.0.0a.tar.gz:chigraph-gui-1.0.0a.tar.gz
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = chigraph-gui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2cf09fbb49ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Russell Greene <russellgreene8 at gmail dot com>
+
+pkgname=chigraph-gui
+pkgver=1.0.0a
+pkgrel=1
+arch=('i686' 'x86_64')
+
+conflicts=("chigraph-gui-git")
+
+pkgdesc="The GUI for chigraph, a visual programming language"
+url='https://github.com/chigraph/chigraph'
+
+depends=('chigraph' 'kxmlgui' 'ktexteditor')
+makedepends=('cmake' 'extra-cmake-modules' 'tar' 'gzip')
+
+source=("https://github.com/russelltg/nodeeditor/archive/v${pkgver}.tar.gz:nodeeditor-${pkgver}.tar.gz" \
+ "https://github.com/chigraph/chigraph-gui/archive/v${pkgver}.tar.gz:chigraph-gui-${pkgver}.tar.gz")
+md5sums=('SKIP' 'SKIP')
+
+prepare() {
+
+ mkdir -p build
+
+ tar xf chigraph-gui-${pkgver}.tar.gz
+ cd chigraph-gui-${pkgver}/third_party/nodeeditor
+
+ tar xf ../../../nodeeditor-${pkgver}.tar.gz --strip-components=1
+
+}
+
+build() {
+ cd build
+ cmake ../chigraph-gui-${pkgver} -DCMAKE_BUILD_TYPE=Release -DCG_USE_SYSTEM_CHIGRAPH=ON -DCMAKE_INSTALL_PREFIX=/usr
+ make -j`nproc`
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}