summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRanieri Althoff2019-01-14 19:51:12 -0200
committerRanieri Althoff2019-01-14 21:11:10 -0200
commitf705ba87df5b44bcef01db95694baf9ee61c620e (patch)
tree46d6dfe5418fc5d26ae634de1d410a4a470f6ce4
downloadaur-chili-sddm-theme.tar.gz
Add files for v0.1.5
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD18
-rw-r--r--chili-sddm-theme.install6
4 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e0351b182c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = chili-sddm-theme
+ pkgdesc = Chili theme for SDDM
+ pkgver = 0.1.5
+ pkgrel = 1
+ url = https://github.com/MarianArlt/sddm-chili
+ install = chili-sddm-theme.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt5-graphicaleffects
+ depends = qt5-quickcontrols
+ depends = sddm
+ source = https://github.com/MarianArlt/sddm-chili/archive/0.1.5.tar.gz
+ sha256sums = a3c0607bf70f448fff0a271624e3bc15af978894c04c98355d00a57431e49a0f
+
+pkgname = chili-sddm-theme
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ccdadf693590
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+
+# Created by https://www.gitignore.io/api/archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..236afb42fe36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Ranieri Althoff <ranisalt+aur at gmail dot com>
+
+pkgname=chili-sddm-theme
+pkgver=0.1.5
+pkgrel=1
+pkgdesc='Chili theme for SDDM'
+arch=('i686' 'x86_64')
+url="https://github.com/MarianArlt/sddm-chili"
+license=('GPL3')
+depends=(qt5-graphicaleffects qt5-quickcontrols sddm)
+install="$pkgname.install"
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=('a3c0607bf70f448fff0a271624e3bc15af978894c04c98355d00a57431e49a0f')
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/sddm/themes"
+ cp -r "${srcdir}/sddm-chili-${pkgver}" "${pkgdir}/usr/share/sddm/themes/chili"
+}
diff --git a/chili-sddm-theme.install b/chili-sddm-theme.install
new file mode 100644
index 000000000000..4d086566a243
--- /dev/null
+++ b/chili-sddm-theme.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo "To use this theme, add the following lines to /etc/sddm.conf.d/theme.conf:"
+ echo
+ echo "[Theme]"
+ echo "Current=chili"
+}