summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2017-02-26 19:09:09 -0800
committerMike Swanson2017-02-26 19:09:09 -0800
commit04d5598a899aa714c7d3dae3fdfc5d11bd783a03 (patch)
tree4e2c72dcaaee5c1d169639ef683c5ff1bcd6ea52
parent13c5b9601b1340bf3e216ac5568b44a8ebf89cbf (diff)
downloadaur-04d5598a899aa714c7d3dae3fdfc5d11bd783a03.tar.gz
Move sdl_net to depends, use sha512sums instead of sha256sums.
sdl_net is required to build, so this package failed to build on a clean system (eg, in ccm). Could have moved it into makedepends, but it was easy enough this way. sha512 is faster to compute than sha256. The difference is negligible for Chocolate Doom, but I'll standardize all my packages on it.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD7
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5df738cadfb0..aee3a3170afe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Dec 30 02:17:03 UTC 2016
+# Mon Feb 27 03:03:12 UTC 2017
pkgbase = chocolate-doom
pkgdesc = Historically-accurate Doom, Heretic, Hexen, and Strife ports.
pkgver = 2.3.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.chocolate-doom.org/
arch = i686
arch = x86_64
@@ -12,16 +12,18 @@ pkgbase = chocolate-doom
depends = libpng
depends = libsamplerate
depends = sdl_mixer
+ depends = sdl_net
source = http://chocolate-doom.org/downloads/2.3.0/chocolate-doom-2.3.0.tar.gz
source = http://chocolate-doom.org/downloads/2.3.0/chocolate-doom-2.3.0.tar.gz.asc
- sha256sums = 3e6d1a82ac5c8b025a9695ce1e47d0dc6ed142ebb1129b1e4a70e2740f79150c
- sha256sums = SKIP
+ sha512sums = 43353875f76432123336ac7f8a37d00c447286f5bf17c2a12f6307568fe2533370ca8e5e0f76fa475e353f20dfdea79e3948c47ea8b079ef5dd9d0a53c305bfc
+ sha512sums = SKIP
pkgname = chocolate-doom
pkgdesc = Doom port accurately reproducing the original DOS EXEs.
depends = libpng
depends = libsamplerate
depends = sdl_mixer
+ depends = sdl_net
depends = chocolate-common
optdepends = freedm: Free deathmatch game
optdepends = freedoom1: Free Ultimate Doom-compatible game (not vanilla compatible, but useful for mods)
@@ -32,6 +34,7 @@ pkgname = chocolate-heretic
depends = libpng
depends = libsamplerate
depends = sdl_mixer
+ depends = sdl_net
depends = chocolate-common
optdepends = blasphemer: Free Heretic-compatible game
@@ -40,6 +43,7 @@ pkgname = chocolate-hexen
depends = libpng
depends = libsamplerate
depends = sdl_mixer
+ depends = sdl_net
depends = chocolate-common
pkgname = chocolate-strife
@@ -47,10 +51,10 @@ pkgname = chocolate-strife
depends = libpng
depends = libsamplerate
depends = sdl_mixer
+ depends = sdl_net
depends = chocolate-common
pkgname = chocolate-common
pkgdesc = Files shared in common with Chocolate Doom-based games.
install = chocolate-doom.install
- depends = sdl_net
diff --git a/PKGBUILD b/PKGBUILD
index 229a9998aa27..9a90f417a27c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@ pkgname=(chocolate-{doom,heretic,hexen,strife,common})
pkgbase=${pkgname[0]}
pkgdesc="Historically-accurate Doom, Heretic, Hexen, and Strife ports."
pkgver=2.3.0
-pkgrel=2
+pkgrel=3
arch=('i686' 'x86_64')
url="http://www.chocolate-doom.org/"
license=('GPL2')
-depends=('libpng' 'libsamplerate' 'sdl_mixer')
+depends=('libpng' 'libsamplerate' 'sdl_mixer' 'sdl_net')
makedepends=('python')
source=(http://chocolate-doom.org/downloads/${pkgver}/${pkgbase}-${pkgver}.tar.gz{,.asc})
-sha256sums=('3e6d1a82ac5c8b025a9695ce1e47d0dc6ed142ebb1129b1e4a70e2740f79150c'
+sha512sums=('43353875f76432123336ac7f8a37d00c447286f5bf17c2a12f6307568fe2533370ca8e5e0f76fa475e353f20dfdea79e3948c47ea8b079ef5dd9d0a53c305bfc'
'SKIP')
validpgpkeys=('6D2C117E0310664497AA9546F6C2EE9C23354344')
@@ -36,7 +36,6 @@ build() {
package_chocolate-common() {
pkgdesc="Files shared in common with Chocolate Doom-based games."
- depends=('sdl_net')
install=chocolate-doom.install
cd "${pkgbase}-${pkgver}"