summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2014-10-22 01:20:59 -0700
committerMike Swanson2014-10-22 01:20:59 -0700
commitc32774f161451cfd561483ef458493df24b4d94f (patch)
tree75fa36f1e03a41e7e82a866bc315533d9702bad7
parent2b6d8e1e618a7ba11f573d5f157afb22411de7e7 (diff)
downloadaur-c32774f161451cfd561483ef458493df24b4d94f.tar.gz
Update chocolate-doom to 2.1.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD45
-rw-r--r--chocolate-doom.install7
3 files changed, 41 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1dadbe449f38..1a6a5549fafd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = chocolate-doom
pkgdesc = Historically-accurate Doom, Heretic, Hexen, and Strife ports.
- pkgver = 2.0.0
- pkgrel = 4
+ pkgver = 2.1.0
+ pkgrel = 1
url = http://www.chocolate-doom.org/
- install = chocolate-doom.install
arch = i686
arch = x86_64
license = GPL2
@@ -12,8 +11,8 @@ pkgbase = chocolate-doom
depends = libsamplerate
depends = sdl_mixer
depends = sdl_net
- source = http://chocolate-doom.org/downloads/2.0.0/chocolate-doom-2.0.0.tar.gz
- sha256sums = 85c58b77dad933013253b453ef01907492b4719acd56cf8cb6c76f4a361ab60c
+ source = http://chocolate-doom.org/downloads/2.1.0/chocolate-doom-2.1.0.tar.gz
+ sha256sums = 629305e7f328659f3e93e89b93adc9da4e99b5a351e51ceb749dcf3e3da8bcd3
pkgname = chocolate-doom
pkgdesc = Doom port accurately reproducing the original DOS EXEs.
@@ -21,6 +20,9 @@ pkgname = chocolate-doom
depends = sdl_mixer
depends = sdl_net
depends = chocolate-common
+ optdepends = freedm: Free deathmatch game
+ optdepends = freedoom1: Free Ultimate Doom-compatible game (not vanilla compatible, but useful for mods)
+ optdepends = freedoom2: Free Doom II/Final Doom-compatible game (not vanilla compatible, but useful for mods)
pkgname = chocolate-heretic
pkgdesc = Heretic port accurately reproducing the original DOS EXEs.
@@ -28,6 +30,7 @@ pkgname = chocolate-heretic
depends = sdl_mixer
depends = sdl_net
depends = chocolate-common
+ optdepends = blasphemer: Free Heretic-compatible game
pkgname = chocolate-hexen
pkgdesc = Hexen port accurately reproducing the original DOS EXEs.
@@ -45,5 +48,6 @@ pkgname = chocolate-strife
pkgname = chocolate-common
pkgdesc = Files shared in common with Chocolate Doom-based games.
+ install = chocolate-doom.install
depends = sdl_net
diff --git a/PKGBUILD b/PKGBUILD
index f7f7ded952c8..6570dd95712f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
pkgname=(chocolate-{doom,heretic,hexen,strife,common})
-_pkgname=${pkgname[0]}
+pkgbase=${pkgname[0]}
pkgdesc="Historically-accurate Doom, Heretic, Hexen, and Strife ports."
-pkgver=2.0.0
-pkgrel=4
+pkgver=2.1.0
+pkgrel=1
arch=('i686' 'x86_64')
url="http://www.chocolate-doom.org/"
license=('GPL2')
depends=('libsamplerate' 'sdl_mixer' 'sdl_net')
makedepends=('autoconf' 'python')
-install=chocolate-doom.install
-source=(http://chocolate-doom.org/downloads/${pkgver}/${_pkgname}-${pkgver}.tar.gz)
-sha256sums=('85c58b77dad933013253b453ef01907492b4719acd56cf8cb6c76f4a361ab60c')
+source=(http://chocolate-doom.org/downloads/${pkgver}/${pkgbase}-${pkgver}.tar.gz)
+sha256sums=('629305e7f328659f3e93e89b93adc9da4e99b5a351e51ceb749dcf3e3da8bcd3')
build() {
- cd "${_pkgname}-${pkgver}"
+ cd "${pkgbase}-${pkgver}"
# Change binary dir from /usr/games to /usr/bin
sed 's|/games|/bin|g' -i src{,/setup}/Makefile.am
@@ -28,8 +27,9 @@ build() {
package_chocolate-common() {
pkgdesc="Files shared in common with Chocolate Doom-based games."
depends=('sdl_net')
+ install=chocolate-doom.install
- cd "${_pkgname}-${pkgver}"
+ cd "${pkgbase}-${pkgver}"
make DESTDIR="${pkgdir}" install
install -dm 755 "${pkgdir}"/usr/share/games/doom
@@ -39,17 +39,20 @@ package_chocolate-common() {
cd "${pkgdir}"/usr/share
rm -rf doc man/man5
- rm -rf applications/chocolate-doom.desktop applications/screensavers \
- icons/chocolate-doom.png
+ rm -rf applications/chocolate-{doom,heretic,hexen,strife}.desktop \
+ applications/screensavers
cd man/man6
- rm -f chocolate-{doom,heretic,hexen,strife}.6
+ rm -f chocolate-{doom,heretic,hexen,strife}{,-setup}.6
}
package_chocolate-doom() {
pkgdesc="Doom port accurately reproducing the original DOS EXEs."
depends=(${depends[@]} 'chocolate-common')
+ optdepends=('freedm: Free deathmatch game'
+ 'freedoom1: Free Ultimate Doom-compatible game (not vanilla compatible, but useful for mods)'
+ 'freedoom2: Free Doom II/Final Doom-compatible game (not vanilla compatible, but useful for mods)')
- cd "${_pkgname}-${pkgver}"
+ cd "${pkgbase}-${pkgver}"
make DESTDIR="${pkgdir}" install
cd "${pkgdir}"/usr/bin
@@ -58,7 +61,7 @@ package_chocolate-doom() {
cd "${pkgdir}"/usr/share
rm -rf doc/chocolate-{heretic,hexen,strife}
- rm -f applications/chocolate-setup.desktop icons/chocolate-setup.png
+ rm -rf applications/chocolate-{setup,heretic,hexen,strife}.desktop icons
rm -f man/man?/chocolate-{heretic,hexen,strife,setup,server}* \
man/man5/{heretic,hexen,strife}.cfg*
}
@@ -66,8 +69,9 @@ package_chocolate-doom() {
package_chocolate-heretic() {
pkgdesc="Heretic port accurately reproducing the original DOS EXEs."
depends=(${depends[@]} 'chocolate-common')
+ optdepends=('blasphemer: Free Heretic-compatible game')
- cd "${_pkgname}-${pkgver}"
+ cd "${pkgbase}-${pkgver}"
make DESTDIR="${pkgdir}" install
cd "${pkgdir}"/usr/bin
@@ -76,7 +80,8 @@ package_chocolate-heretic() {
cd "${pkgdir}"/usr/share
rm -rf doc/chocolate-{doom,hexen,strife}
- rm -rf applications icons
+ rm -rf applications/chocolate-{setup,doom,hexen,strife}.desktop \
+ applications/screensavers icons
rm -f man/man?/chocolate-{doom,hexen,strife,setup,server}* \
man/man5/{default,hexen,strife}.cfg*
}
@@ -85,7 +90,7 @@ package_chocolate-hexen() {
pkgdesc="Hexen port accurately reproducing the original DOS EXEs."
depends=(${depends[@]} 'chocolate-common')
- cd "${_pkgname}-${pkgver}"
+ cd "${pkgbase}-${pkgver}"
make DESTDIR="${pkgdir}" install
cd "${pkgdir}"/usr/bin
@@ -94,7 +99,8 @@ package_chocolate-hexen() {
cd "${pkgdir}"/usr/share
rm -rf doc/chocolate-{doom,heretic,strife}
- rm -rf applications icons
+ rm -rf applications/chocolate-{setup,doom,heretic,strife}.desktop \
+ applications/screensavers icons
rm -f man/man?/chocolate-{doom,heretic,strife,setup,server}* \
man/man5/{default,heretic,strife}.cfg*
}
@@ -103,7 +109,7 @@ package_chocolate-strife() {
pkgdesc="Strife port accurately reproducing the original DOS EXEs."
depends=(${depends[@]} 'chocolate-common')
- cd "${_pkgname}-${pkgver}"
+ cd "${pkgbase}-${pkgver}"
make DESTDIR="${pkgdir}" install
cd "${pkgdir}"/usr/bin
@@ -112,7 +118,8 @@ package_chocolate-strife() {
cd "${pkgdir}"/usr/share
rm -rf doc/chocolate-{doom,heretic,hexen}
- rm -rf applications icons
+ rm -rf applications/chocolate-{setup,doom,heretic,hexen}.desktop \
+ applications/screensavers icons
rm -f man/man?/chocolate-{doom,heretic,hexen,setup,server}* \
man/man5/{default,heretic,hexen}.cfg*
}
diff --git a/chocolate-doom.install b/chocolate-doom.install
index 0a95a48c7861..5a701f56e333 100644
--- a/chocolate-doom.install
+++ b/chocolate-doom.install
@@ -1,3 +1,8 @@
post_install() {
- echo "Copy any IWAD files to the global default /usr/share/games/doom"
+ echo "Install IWADs into /usr/share/games/doom or /usr/local/share/games/doom"
+ echo ""
+ echo "Files such as doom2.wad, heretic.wad, hexen.wad, strife1.wad"
+ echo "are IWADs appropriate for installation and usage with Chocolate"
+ echo "engines. These must be lower-case file names unless using a"
+ echo "case-insensitive file system."
}