summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2020-05-16 21:04:29 -0700
committerMike Swanson2020-05-16 21:04:29 -0700
commitf64526a4c2e8558c3e7c0e73c0454aa8c7872352 (patch)
tree5aaad385ce826833e6bd59de3bf816650168048e
parentd8f3d40e702246d4ccca5303965a5b712aebe20c (diff)
downloadaur-f64526a4c2e8558c3e7c0e73c0454aa8c7872352.tar.gz
Fix compilation under GCC 10
-rw-r--r--.SRCINFO10
-rw-r--r--0002-Remove-redundant-demoextend-definition.patch28
-rw-r--r--PKGBUILD12
3 files changed, 41 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4679f53acc6..27aa6a48f90c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = chocolate-doom
pkgdesc = Historically-accurate Doom, Heretic, Hexen, and Strife ports.
pkgver = 3.0.0
- pkgrel = 4
+ pkgrel = 5
url = http://www.chocolate-doom.org/
install = chocolate-doom.install
arch = i686
@@ -26,10 +26,12 @@ pkgbase = chocolate-doom
source = https://www.chocolate-doom.org/downloads/3.0.0/chocolate-doom-3.0.0.tar.gz
source = https://www.chocolate-doom.org/downloads/3.0.0/chocolate-doom-3.0.0.tar.gz.asc
source = 0001_fix-bash-completion.patch
+ source = 0002-Remove-redundant-demoextend-definition.patch
validpgpkeys = 6D2C117E0310664497AA9546F6C2EE9C23354344
- sha512sums = 41f235c0d84ef21070636ad0610e97898dfd366fae7f9244bd2aebf8974db98dcf55f70bcab2f93589b9bf31dd421db32e8af88e0f8e0a655d2b9f1d4ead2afd
- sha512sums = SKIP
- sha512sums = 5da61fcabd332698b3a8934670195d42f9d9db949fd666c3a670c47252af0376cf8cd0e3f2d78c9d6593446d68dab02b3db14b995a9fa8c973859cd2fd8bc3d0
+ b2sums = 11989b4b4458098af63c4b89a73552a8bb43c22077d358770b0e89e1b816950b92630592dcb5b4a782ccf673951b7e3d8503bc517577fe59d052d8b4f3f125e1
+ b2sums = SKIP
+ b2sums = 15115b4450f978b6ce2c593ec3d7d54d6acc1082b64b1fb0db155187366595563291991d19840534a43d966bf4722954e652b3cb3e9961d5ad6827c3651c0908
+ b2sums = eefc539dd87472323be368073ac2893f41a0ce478d12a288bb1b85513f1491b013fcdfcac94db92e444fe89798ffb06a0441e016f78cf533221fffc9e1f69507
pkgname = chocolate-doom
diff --git a/0002-Remove-redundant-demoextend-definition.patch b/0002-Remove-redundant-demoextend-definition.patch
new file mode 100644
index 000000000000..f57606a41bca
--- /dev/null
+++ b/0002-Remove-redundant-demoextend-definition.patch
@@ -0,0 +1,28 @@
+From bec768e37bb49d8f8c4dcbda49e746c2f6f4b41b Mon Sep 17 00:00:00 2001
+From: Jordan Christiansen <xordspar0@gmail.com>
+Date: Sun, 15 Mar 2020 16:55:33 -0500
+Subject: [PATCH] Remove redundant demoextend definition
+
+GCC 10 enables -fno-common by default, which causes the linker to fail when
+there are multple definitions of a global variable.
+
+See https://gcc.gnu.org/gcc-10/porting_to.html
+---
+ src/hexen/mn_menu.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/hexen/mn_menu.c b/src/hexen/mn_menu.c
+index a3ff99980..b9ad45eea 100644
+--- a/src/hexen/mn_menu.c
++++ b/src/hexen/mn_menu.c
+@@ -131,7 +131,6 @@ boolean MenuActive;
+ int InfoType;
+ int messageson = true;
+ boolean mn_SuicideConsole;
+-boolean demoextend; // from h2def.h
+
+ // PRIVATE DATA DEFINITIONS ------------------------------------------------
+
+--
+2.26.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 1a421aa7d6b7..248cc4752f2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=chocolate-doom
pkgdesc="Historically-accurate Doom, Heretic, Hexen, and Strife ports."
pkgver=3.0.0
-pkgrel=4
+pkgrel=5
arch=('i686' 'x86_64')
url="http://www.chocolate-doom.org/"
license=('GPL2')
@@ -19,10 +19,12 @@ conflicts=(chocolate-common
chocolate-strife)
replaces=(${conflicts[@]})
source=(https://www.chocolate-doom.org/downloads/${pkgver}/${pkgname}-${pkgver}.tar.gz{,.asc}
- 0001_fix-bash-completion.patch)
-sha512sums=('41f235c0d84ef21070636ad0610e97898dfd366fae7f9244bd2aebf8974db98dcf55f70bcab2f93589b9bf31dd421db32e8af88e0f8e0a655d2b9f1d4ead2afd'
- 'SKIP'
- '5da61fcabd332698b3a8934670195d42f9d9db949fd666c3a670c47252af0376cf8cd0e3f2d78c9d6593446d68dab02b3db14b995a9fa8c973859cd2fd8bc3d0')
+ 0001_fix-bash-completion.patch
+ 0002-Remove-redundant-demoextend-definition.patch)
+b2sums=('11989b4b4458098af63c4b89a73552a8bb43c22077d358770b0e89e1b816950b92630592dcb5b4a782ccf673951b7e3d8503bc517577fe59d052d8b4f3f125e1'
+ 'SKIP'
+ '15115b4450f978b6ce2c593ec3d7d54d6acc1082b64b1fb0db155187366595563291991d19840534a43d966bf4722954e652b3cb3e9961d5ad6827c3651c0908'
+ 'eefc539dd87472323be368073ac2893f41a0ce478d12a288bb1b85513f1491b013fcdfcac94db92e444fe89798ffb06a0441e016f78cf533221fffc9e1f69507')
validpgpkeys=('6D2C117E0310664497AA9546F6C2EE9C23354344')
prepare() {