summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2019-09-16 17:28:21 -0700
committerMike Swanson2019-09-16 17:28:21 -0700
commitc5e5458b3de1ad2e07eaefa1213c2fc3dad29250 (patch)
treee5c0e2c043423d9c291b61ca474e83e30e121ba7
parent775654945cc78dfa70843c782f8bea311b4b7ebc (diff)
downloadaur-chocolate-doom-git.tar.gz
Bring into sync with release PKGBUILD: dedup setup programs
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b075e6fb0e48..cf4ae433c041 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = chocolate-doom-git
pkgdesc = Historically-accurate Doom, Heretic, Hexen, and Strife ports.
pkgver = 3.0.0.r822.ee9fc21f
- pkgrel = 1
+ pkgrel = 2
url = http://www.chocolate-doom.org/
install = chocolate-doom.install
arch = i686
@@ -15,7 +15,7 @@ pkgbase = chocolate-doom-git
depends = sdl2_net
optdepends = freedm: Free deathmatch game
optdepends = freedoom1: Free Ultimate Doom-compatible game
- optdepends = freedoom2: Free Doom II/Final Doom-compatible game
+ optdepends = freedoom2: Free Doom II-compatible game
conflicts = chocolate-common
conflicts = chocolate-doom
conflicts = chocolate-heretic
diff --git a/PKGBUILD b/PKGBUILD
index d255677bed62..e08710af5435 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=chocolate-doom-git
pkgdesc="Historically-accurate Doom, Heretic, Hexen, and Strife ports."
pkgver=3.0.0.r822.ee9fc21f
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="http://www.chocolate-doom.org/"
license=('GPL2')
@@ -12,7 +12,7 @@ depends=('libpng' 'libsamplerate' 'sdl2_mixer' 'sdl2_net')
makedepends=('git' 'python')
optdepends=('freedm: Free deathmatch game'
'freedoom1: Free Ultimate Doom-compatible game'
- 'freedoom2: Free Doom II/Final Doom-compatible game')
+ 'freedoom2: Free Doom II-compatible game')
conflicts=(chocolate-common
chocolate-doom
chocolate-heretic
@@ -42,4 +42,13 @@ package() {
cd "${pkgname/-git//}"
make DESTDIR="${pkgdir}" install
+ install -dm 755 "${pkgdir}"/usr/share/games/doom
+
+ # dedup all the *setup programs, make desktop file work
+ rm "${pkgdir}"/usr/bin/chocolate-{heretic,hexen,strife}-setup
+ mv "${pkgdir}"/usr/bin/chocolate-doom-setup "${pkgdir}"/usr/bin/chocolate-setup
+ ln -s chocolate-setup "${pkgdir}"/usr/bin/chocolate-doom-setup
+ ln -s chocolate-setup "${pkgdir}"/usr/bin/chocolate-heretic-setup
+ ln -s chocolate-setup "${pkgdir}"/usr/bin/chocolate-hexen-setup
+ ln -s chocolate-setup "${pkgdir}"/usr/bin/chocolate-strife-setup
}