summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFredy García2022-09-21 19:27:57 -0500
committerFredy García2022-09-21 19:27:57 -0500
commit625e85679a5b66bbd5e45d66c08ed2162463f0dc (patch)
treeff26b4819cae86e7baf48aa2488361b07e4bc78d
parentd1215467e8e9ae7914cc0d3bf7a019213c03afef (diff)
downloadaur-625e85679a5b66bbd5e45d66c08ed2162463f0dc.tar.gz
Upgrading to version 106.0.5249.37 Using tput only when supported.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--chrome-remote-desktop.install49
3 files changed, 41 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b544ff1e44d..b00feb35af0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chrome-remote-desktop
pkgdesc = Access other computers or allow another user to access your computer securely over the Internet
- pkgver = 105.0.5195.14
+ pkgver = 106.0.5249.37
pkgrel = 1
url = https://remotedesktop.google.com
install = chrome-remote-desktop.install
@@ -16,11 +16,11 @@ pkgbase = chrome-remote-desktop
depends = xorg-xauth
depends = xorg-xdpyinfo
depends = xorg-xrandr
- source = chrome-remote-desktop-105.0.5195.14.deb::https://dl.google.com/linux/chrome-remote-desktop/deb/pool/main/c/chrome-remote-desktop/chrome-remote-desktop_105.0.5195.14_amd64.deb
+ source = chrome-remote-desktop-106.0.5249.37.deb::https://dl.google.com/linux/chrome-remote-desktop/deb/pool/main/c/chrome-remote-desktop/chrome-remote-desktop_106.0.5249.37_amd64.deb
source = chrome-remote-desktop.service
source = pamrule
source = crd
- sha256sums = 1f1b875f42f78603a65e04d56137bdc0c7b10c644d2a402ca8db113b89f3b790
+ sha256sums = 6a6761b9a327ec4bf902aea77ab4f666ef719921533c539584f4d3c64e955eeb
sha256sums = e5da5ae89b5bc599f72f415d1523341b25357931b0de46159fce50ab83615a4b
sha256sums = fcc38269eb1cc902abff9688eda9377a22367e39b9f111f87c0dd8e77adb82e2
sha256sums = 021110f49d465294517eec92eeb24ebca41e264ef33cbdda78732add1f269d02
diff --git a/PKGBUILD b/PKGBUILD
index 42edb9c1165c..d7857b365be8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Mateus Rodrigues Costa <charles [dot] costar [at] gmail [dot] com>
pkgname=chrome-remote-desktop
-pkgver=105.0.5195.14
+pkgver=106.0.5249.37
pkgrel=1
pkgdesc="Access other computers or allow another user to access your computer securely over the Internet"
arch=("x86_64")
@@ -20,7 +20,7 @@ source=(
"crd"
)
sha256sums=(
- "1f1b875f42f78603a65e04d56137bdc0c7b10c644d2a402ca8db113b89f3b790"
+ "6a6761b9a327ec4bf902aea77ab4f666ef719921533c539584f4d3c64e955eeb"
"e5da5ae89b5bc599f72f415d1523341b25357931b0de46159fce50ab83615a4b"
"fcc38269eb1cc902abff9688eda9377a22367e39b9f111f87c0dd8e77adb82e2"
"021110f49d465294517eec92eeb24ebca41e264ef33cbdda78732add1f269d02"
diff --git a/chrome-remote-desktop.install b/chrome-remote-desktop.install
index 5a0990817fba..738c83a49466 100644
--- a/chrome-remote-desktop.install
+++ b/chrome-remote-desktop.install
@@ -2,18 +2,35 @@ post_install() {
# Create chrome-remote-desktop group
[[ $(cat /etc/group) == *chrome-remote-desktop* ]] || groupadd -r chrome-remote-desktop
- printf "$(tput setaf 4)Set up CRD by issuing the command:$(tput sgr0)\n"
- printf "$(tput setaf 2)crd --setup$(tput sgr0)\n"
- printf "$(tput setaf 4)as a normal user.$(tput sgr0)\n\n"
- printf "$(tput setaf 4)After that, enable access to CRD in your chrome or chromium browser.$(tput sgr0)\n\n"
- printf "$(tput setaf 4)To {enable,start} the service, issue the command:$(tput sgr0)\n"
- printf "$(tput setaf 2)systemctl --user {enable,start} chrome-remote-desktop$(tput sgr0)\n"
- printf "$(tput setaf 4)This only really makes sense for servers.$(tput sgr0)\n\n"
- printf "$(tput setaf 4)You can also start the chrome remote desktop server by issuing the command:$(tput sgr0)\n"
- printf "$(tput setaf 2)crd --start$(tput sgr0)\n"
- printf "$(tput setaf 4)as a normal user. $(tput sgr0)\n"
- printf "$(tput setaf 4)This will prompt you to set up your CRD if it hasn't been set up already.$(tput sgr0)\n\n"
- printf "$(tput setaf 4)Go to https://support.google.com/chrome/answer/1649523 for more information.$(tput sgr0)\n"
+ tput setaf 0 2>/dev/null
+ if [[ "$?" == "0" ]]; then
+ tput sgr0
+ printf "$(tput setaf 4)Set up CRD by issuing the command:$(tput sgr0)\n"
+ printf "$(tput setaf 2)crd --setup$(tput sgr0)\n"
+ printf "$(tput setaf 4)as a normal user.$(tput sgr0)\n\n"
+ printf "$(tput setaf 4)After that, enable access to CRD in your chrome or chromium browser.$(tput sgr0)\n\n"
+ printf "$(tput setaf 4)To {enable,start} the service, issue the command:$(tput sgr0)\n"
+ printf "$(tput setaf 2)systemctl --user {enable,start} chrome-remote-desktop$(tput sgr0)\n"
+ printf "$(tput setaf 4)This only really makes sense for servers.$(tput sgr0)\n\n"
+ printf "$(tput setaf 4)You can also start the chrome remote desktop server by issuing the command:$(tput sgr0)\n"
+ printf "$(tput setaf 2)crd --start$(tput sgr0)\n"
+ printf "$(tput setaf 4)as a normal user. $(tput sgr0)\n"
+ printf "$(tput setaf 4)This will prompt you to set up your CRD if it hasn't been set up already.$(tput sgr0)\n\n"
+ printf "$(tput setaf 4)Go to https://support.google.com/chrome/answer/1649523 for more information.$(tput sgr0)\n"
+ else
+ printf "Set up CRD by issuing the command:\n"
+ printf "crd --setup\n"
+ printf "as a normal user.\n\n"
+ printf "After that, enable access to CRD in your chrome or chromium browser.\n\n"
+ printf "To {enable,start} the service, issue the command:\n"
+ printf "systemctl --user {enable,start} chrome-remote-desktop\n"
+ printf "This only really makes sense for servers.\n\n"
+ printf "You can also start the chrome remote desktop server by issuing the command:\n"
+ printf "crd --start\n"
+ printf "as a normal user. \n"
+ printf "This will prompt you to set up your CRD if it hasn't been set up already.\n\n"
+ printf "Go to https://support.google.com/chrome/answer/1649523 for more information.\n"
+ fi
}
post_upgrade() {
@@ -21,5 +38,11 @@ post_upgrade() {
}
post_remove() {
- printf "\n$(tput setaf 4)Please remove ~/.config/chrome-remote-desktop folder manually$(tput sgr0)\n\n"
+ tput setaf 0 2>/dev/null
+ if [[ "$?" == "0" ]]; then
+ tput sgr0
+ printf "\n$(tput setaf 4)Please remove ~/.config/chrome-remote-desktop folder manually$(tput sgr0)\n\n"
+ else
+ printf "\nPlease remove ~/.config/chrome-remote-desktop folder manually\n\n"
+ fi
}