summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShayne Hartford (ShayBox)2020-03-27 22:09:46 -0400
committerShayne Hartford (ShayBox)2020-03-27 22:09:46 -0400
commit10534032b998f411931f7771253177b45c9937a8 (patch)
tree593d1559445e0322dbbfef475180fb8234c0c710
parent2a230ba99f9a38b1d7b9f069b8a7b83bfba9b7e8 (diff)
downloadaur-10534032b998f411931f7771253177b45c9937a8.tar.gz
Recreate package
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 21 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9665299404e4..9c0111e8e418 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = chromeos-gtk-theme-git
pkgdesc = A Material Design theme for GNOME/GTK based desktop environments.
- pkgver = 1.218bb0a
+ pkgver = r50.5226421
pkgrel = 1
- url = https://github.com/vinceliuice/ChromeOS-theme
+ url = https://github.com/vinceliuice/chromeos-theme
arch = any
license = GPL3
makedepends = git
- depends = gtk3
- depends = gtk-engine-murrine
- depends = gtk-engines
+ optdepends = gtk-engine-murrine
+ optdepends = gtk-engines
+ provides = chromeos-gtk-theme
options = !strip
- source = git+https://github.com/vinceliuice/ChromeOS-theme
- md5sums = SKIP
+ source = git+https://github.com/vinceliuice/chromeos-theme
+ sha256sums = SKIP
pkgname = chromeos-gtk-theme-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 4572eae877d9..d7b594560d75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
#Maintainer Robosky <fangyuhao0612@gmail.com>
pkgname=chromeos-gtk-theme-git
-_pkgname=ChromeOS-theme
-pkgver=1.218bb0a
+_pkgname=chromeos-theme
+pkgver=r50.5226421
pkgrel=1
pkgdesc='A Material Design theme for GNOME/GTK based desktop environments.'
arch=('any')
-depends=('gtk3' 'gtk-engine-murrine' 'gtk-engines')
-license=('GPL3')
+provides=('chromeos-gtk-theme')
url="https://github.com/vinceliuice/${_pkgname}"
-source=("git+${url}")
-md5sums=('SKIP')
+license=('GPL3')
+optdepends=('gtk-engine-murrine' 'gtk-engines')
makedepends=('git')
+source=("git+${url}")
+sha256sums=('SKIP')
options=('!strip')
pkgver() {
- cd "${srcdir}/${_pkgname}"
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd "$srcdir/$_pkgname"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-
package() {
cd "${srcdir}/${_pkgname}"
install -m755 -d "${pkgdir}/usr/share/themes"