summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoc2023-12-08 18:00:50 +0800
committerRoc2023-12-08 19:35:19 +0800
commitf2af10f4fe88f9151c631cae9215bbf68fd68873 (patch)
tree5bf71804dfcc46cc1b378a13b4d092bb8dcfc493
parent982c6027c41c84f03c0f3f3df05d2110c765a725 (diff)
downloadaur-chromeos-kde-theme-git.tar.gz
update
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 356e6498f7bb..909a7347fdcf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = chromeos-kde-theme-git
pkgdesc = ChromeOS theme for the KDE Plasma desktop.
- pkgver = r28.55d0e85
+ pkgver = r76.383b4a5
pkgrel = 1
url = https://github.com/vinceliuice/ChromeOS-kde
arch = any
license = GPL3
makedepends = git
depends = plasma-desktop
- optdepends = kvantum-qt5
- optdepends = chromeos-gtk-theme-git
- optdepends = tela-icon-theme-git
- optdepends = sddm
- source = chromeos-kde::git+https://github.com/vinceliuice/ChromeOS-kde.git
+ optdepends = kvantum: for included kvantum theme
+ optdepends = chromeos-gtk-theme-git: matching gtk theme
+ optdepends = tela-icon-theme-git: matching icon theme
+ optdepends = sddm: for included sddm theme
+ source = ChromeOS-kde::git+https://github.com/vinceliuice/ChromeOS-kde.git
source = fix-theme-installer-path.patch
sha256sums = SKIP
sha256sums = 3c5ec095be345bc5e560c0f594e1afdef9b2ffef9e3de90c52673382ec85f729
pkgname = chromeos-kde-theme-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c9905073ab9e..9974a095f2d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
+# Maintainer: Roc <roc dot gui at outlook dot com>
# Maintainer: Francois Menning <f.menning@pm.me>
-_gitname=chromeos-kde
+_gitname=ChromeOS-kde
pkgname=chromeos-kde-theme-git
-pkgver=r28.55d0e85
+pkgver=r76.383b4a5
pkgrel=1
pkgdesc="ChromeOS theme for the KDE Plasma desktop."
arch=('any')
-url="https://github.com/vinceliuice/ChromeOS-kde"
+url="https://github.com/vinceliuice/${_gitname}"
license=('GPL3')
depends=('plasma-desktop')
-optdepends=('kvantum-qt5' 'chromeos-gtk-theme-git' 'tela-icon-theme-git' 'sddm')
+optdepends=('kvantum: for included kvantum theme' 'chromeos-gtk-theme-git: matching gtk theme' 'tela-icon-theme-git: matching icon theme' 'sddm: for included sddm theme')
makedepends=('git')
source=(
- "${_gitname}::git+https://github.com/vinceliuice/ChromeOS-kde.git"
+ "${_gitname}::git+${url}.git"
'fix-theme-installer-path.patch'
)
-sha256sums=('SKIP'
- '3c5ec095be345bc5e560c0f594e1afdef9b2ffef9e3de90c52673382ec85f729')
+sha256sums=('SKIP' '3c5ec095be345bc5e560c0f594e1afdef9b2ffef9e3de90c52673382ec85f729')
pkgver() {
cd ${_gitname}
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
prepare () {