summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Clonch2016-02-14 09:47:54 -0500
committerChris Clonch2016-02-14 09:47:54 -0500
commit025811abfc967b87bb6331c23bdbaa061421f645 (patch)
tree147d47dd1a2dd96739ac969be5408395c6463b89
parentdb5181d30813c9464b370a111bacf4129191ba4b (diff)
downloadaur-025811abfc967b87bb6331c23bdbaa061421f645.tar.gz
Update to 0.10.0.
Added MIT license based on other InfluxData projects.
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore1
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD18
4 files changed, 41 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 320b8150bad9..303cff07f7f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
+# Generated by mksrcinfo v8
+# Sun Feb 14 14:47:33 UTC 2016
pkgbase = chronograf
pkgdesc = A new data visualization tool for InfluxDB
- pkgver = 0.3.2
+ pkgver = 0.10.0
pkgrel = 1
url = http://influxdb.org/chronograf
install = chronograf.install
- arch = i686
arch = x86_64
license = MIT
makedepends = go
makedepends = git
backup = etc/chronograf.toml
- source = https://s3.amazonaws.com/get.influxdb.org/chronograf/chronograf_0.3.2_amd64.deb
+ source = https://s3.amazonaws.com/get.influxdb.org/chronograf/chronograf_0.10.0_amd64.deb
source = chronograf.install
source = chronograf.service
- md5sums = 1a8c09b6abf8276408a2b2a4e1eb7e84
+ source = LICENSE
+ md5sums = 6f536cd293a8dd41d0b93a8815c8822c
md5sums = 5eeadbb9b80534dcf87ce3a9131ab75e
md5sums = 396feb4648ea8447c3d69bc97a80b9be
+ md5sums = 51c3bce403f0005b9ef91ab20cc00964
pkgname = chronograf
diff --git a/.gitignore b/.gitignore
index 181b3460e424..26ea83fd2ca2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
*
!PKGBUILD
+!LICENSE
!.SRCINFO
!*.patch
!*.desktop
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..d2f5082cd8e1
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2016 InfluxDB
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index d06b2378cd8f..44eb353128ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Justin Dray <justin@dray.be>
+# Maintainer: Justin Dray <justin@dray.be>
pkgname='chronograf'
-pkgver='0.3.2'
+pkgver='0.10.0'
pkgrel='1'
epoch=
pkgdesc='A new data visualization tool for InfluxDB'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://influxdb.org/chronograf'
license=('MIT')
groups=()
@@ -20,14 +21,16 @@ backup=('etc/chronograf.toml')
options=()
install="$pkgname.install"
pkgtar="v${pkgver}.tar.gz"
-source=("https://s3.amazonaws.com/get.influxdb.org/chronograf/chronograf_0.3.2_amd64.deb"
+source=("https://s3.amazonaws.com/get.influxdb.org/chronograf/chronograf_${pkgver}_amd64.deb"
"$pkgname.install"
- "$pkgname.service")
+ "$pkgname.service"
+ "LICENSE")
changelog=
noextract=()
-md5sums=('1a8c09b6abf8276408a2b2a4e1eb7e84'
+md5sums=('6f536cd293a8dd41d0b93a8815c8822c'
'5eeadbb9b80534dcf87ce3a9131ab75e'
- '396feb4648ea8447c3d69bc97a80b9be')
+ '396feb4648ea8447c3d69bc97a80b9be'
+ '51c3bce403f0005b9ef91ab20cc00964')
prepare() {
bsdtar xf data.tar.gz
@@ -44,4 +47,7 @@ package() {
# configuration file
install -D -m644 "$srcdir/opt/chronograf/config.toml" "$pkgdir/etc/chronograf.toml"
+
+ # license file
+ install -D -m644 "$srcdir/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}