summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXIE Yuheng2015-07-21 22:27:15 +0800
committerXIE Yuheng2015-07-21 22:27:15 +0800
commitec833ad71647d17a7107e33957aedb1e6e5234ea (patch)
tree45da114bec7f28832e83dc9612110ca6699b7265
downloadaur-cicada.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--cicada.install40
-rw-r--r--makefile40
4 files changed, 127 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98e2eebedf55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cicada
+ pkgdesc = programming language with the following features 1. threaded code based 2. aggressively developed 3. never provide backward compatibility [github zip version]
+ pkgver = 2015.06.24
+ pkgrel = 1
+ url = http://cicada-language.github.io/
+ install = cicada.install
+ arch = any
+ license = custom
+ depends = fasm-linux-git
+ provides = cicada
+ conflicts = cicada-git
+ source = https://github.com/cicada-language/cicada/archive/master.zip
+ md5sums = SKIP
+
+pkgname = cicada
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07cde749606a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: XIE Yuheng <xyheme@gmail.com>
+
+pkgname=cicada
+pkgver=2015.06.24
+pkgrel=1
+pkgdesc="programming language with the following features
+1. threaded code based
+2. aggressively developed
+3. never provide backward compatibility
+[github zip version]"
+url="http://cicada-language.github.io/"
+makedepends=('')
+depends=('fasm-linux-git')
+license=('custom')
+arch=('any')
+source=('https://github.com/cicada-language/cicada/archive/master.zip')
+provides=('cicada')
+conflicts=('cicada-git')
+md5sums=('SKIP')
+install=cicada.install
+
+build() {
+ cd "$srcdir/cicada-master"
+ make build
+}
+
+package() {
+ cd "$srcdir/cicada-master"
+ make PREFIX="$pkgdir/usr" install
+ install -D -m644 LICENSE/LICENSE-of-cicada -t "${pkgdir}/usr/share/licenses/cicada"
+} \ No newline at end of file
diff --git a/cicada.install b/cicada.install
new file mode 100644
index 000000000000..c43ffd51427b
--- /dev/null
+++ b/cicada.install
@@ -0,0 +1,40 @@
+## arg 1: the new package version
+pre_upgrade() {
+ echo -e " \e[33;1m"
+ echo "* updating cicada-language"
+ echo " version : " $1
+ echo " the language is still in its primitive stage"
+ echo -e "\e[0m "
+}
+
+## arg 1: the new package version
+pre_install() {
+ echo -e " \e[33;1m"
+ echo "* installing cicada-language"
+ echo " version : " $1
+ echo " the language is still in its primitive stage"
+ echo "* installed programs are as following :"
+ echo " 1. cn"
+ echo " it denotes cicada-nymph"
+ echo " it is cicada-nymph's interpreter"
+ echo " 2. cn32"
+ echo " 32bit version of cn"
+ echo " more programs will coming soon :)"
+ echo -e "\e[0m "
+}
+
+## arg 1: the new package version
+post_install() {
+ echo -e " \e[33;1m"
+ echo "* thank you for installing cicada-language"
+ echo " I wish you have fun playing with it ^-^"
+ echo -e "\e[0m "
+}
+
+## arg 1: the new package version
+post_upgrade() {
+ echo -e " \e[33;1m"
+ echo "* cicada-language is up to date ^-^"
+ echo " I wish you a lovely day { or night :P }"
+ echo -e "\e[0m "
+}
diff --git a/makefile b/makefile
new file mode 100644
index 000000000000..0583087c732f
--- /dev/null
+++ b/makefile
@@ -0,0 +1,40 @@
+.ONESHELL:
+
+DIR=cicada-master
+PKG=cicada
+
+all:
+ @
+ make build &&\
+ make ball
+build:
+ @
+ makepkg -sf
+
+ball:
+ @
+ mkaurball -f
+
+install:
+ @
+ pacman -U $(PKG)-*.pkg.tar.xz
+
+clean*~:
+ @
+ rm -f *~ */*~ */*/*~ */*/*/*~ */*/*/*/*~ */*/*/*/*/*~
+
+clean*.bin:
+ @
+ rm -f *.bin */*.bin */*/*.bin */*/*/*.bin */*/*/*/*.bin */*/*/*/*/*.bin
+
+clean:
+ @
+ make clean*~
+ make clean*.bin
+ rm $(PKG)-*.pkg.tar.xz
+ rm $(PKG)-*.src.tar.gz
+ rm -rf *.zip
+ rm -rf src
+ rm -rf pkg
+ rm -rf $(DIR)
+ echo -e "\e[33;1m [ok] clean directory \e[0m"