summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilan Knížek2015-06-24 13:35:40 +0200
committerMilan Knížek2015-06-24 13:35:40 +0200
commitdb6ca0dea26dba86f7d13504cb481df68d7ce57d (patch)
treed719fcaa9ed6c10a0b7898274fb0019164dab43c
downloadaur-cinepaint-oyranos.tar.gz
Initial commit
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD52
-rw-r--r--cinepaint.install13
3 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50118e877a95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = cinepaint-oyranos
+ pkgdesc = Oyranos enabled version of photo editing application.
+ pkgver = 0.25.2
+ pkgrel = 1
+ url = http://www.cinepaint.org
+ install = cinepaint.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ license = GPL
+ license = MIT
+ makedepends = python2
+ makedepends = gutenprint>=5.2.9
+ makedepends = git
+ depends = gtk2
+ depends = openexr
+ depends = lcms
+ depends = libxpm
+ depends = fltk
+ depends = ftgl
+ depends = libxxf86vm
+ depends = oyranos>=0.9.0
+ optdepends = python2: for python plug-ins
+ optdepends = gutenprint: for print plug-ins
+ optdepends = ghostscript: for pdf plug-ins
+ provides = cinepaint
+ conflicts = cinepaint
+ options = !libtool
+ source = https://github.com/milankni/cinepaint-oyranos/archive/release-0.25.2.tar.gz
+ md5sums = 23c365599a1ce76ad75b5a2c98d2d070
+
+pkgname = cinepaint-oyranos
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d7f85c8cf63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: tobias [tobias.archlinux.org]
+# Contributor: tobias [tobias.justdreams.de]
+
+pkgname=cinepaint-oyranos
+_pkgname=cinepaint-oyranos-release
+pkgver=0.25.2
+pkgrel=1
+pkgdesc="Oyranos enabled version of photo editing application."
+arch=('i686' 'x86_64')
+license=('LGPL' 'GPL' 'MIT')
+url="http://www.cinepaint.org"
+depends=('gtk2' 'openexr' 'lcms' 'libxpm' 'fltk' 'ftgl' 'libxxf86vm' 'oyranos>=0.9.0')
+makedepends=('python2' 'gutenprint>=5.2.9' 'git')
+optdepends=('python2: for python plug-ins'
+ 'gutenprint: for print plug-ins'
+ 'ghostscript: for pdf plug-ins')
+conflicts=(cinepaint)
+provides=(cinepaint)
+options=('!libtool')
+install=cinepaint.install
+source=("https://github.com/milankni/$pkgname/archive/release-$pkgver.tar.gz")
+
+build(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ # These flags lead to failure during compilation. Why?
+ #export LDFLAGS="$LDFLAGS -lstdc++ -lm -lX11"
+
+ # CinePaint may crash due to buffer overflow when entering Preferences
+ # or choosing an ICC profile.
+ # This is due to some problems with a particular ICC profile on user's
+ # system.
+ # Workaround is:
+ # x either to compile with --enable-debug (add it to configure line)
+ # x or to run LANG=C cinepaint
+ # x or to remove the troublesome ICC Profile
+
+ #sh autogen.sh
+ ./configure --prefix=/usr --libdir=/usr/lib --mandir=/usr/share/man \
+ --enable-pygimp --with-python=/usr/bin/python2
+
+ # Probably not needed anymore
+ #find . -name Makefile -exec sed -i 's/-Wl,,/-Wl,/g' {} +
+
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 "COPYING" "${pkgdir}/usr/share/licenses/cinepaint/COPYING"
+}
+md5sums=('23c365599a1ce76ad75b5a2c98d2d070')
diff --git a/cinepaint.install b/cinepaint.install
new file mode 100644
index 000000000000..9dedd00a1674
--- /dev/null
+++ b/cinepaint.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-desktop-database -q
+ echo "==> ICC Examin plugin must be compiled _after_ CinePaint is installed."
+}
+
+post_upgrade() {
+ update-desktop-database -q
+ echo "==> If ICC Examin plugin fails, recompile it from AUR."
+}
+
+post_remove() {
+ update-desktop-database -q
+}