summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan2016-04-22 16:31:53 +0200
committerJan2016-04-22 16:31:53 +0200
commit463cff77563fd6ddbd2432f32e67076883ba0780 (patch)
tree131a99851b504f2704abaf2c60581caf4f6ecec2
downloadaur-cinnamon-applet-cpu-temperatur-git.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD26
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2872775e9d31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cinnamon-applet-cpu-temperatur-git
+ pkgdesc = Shows CPU Temperature on Cinnamon panel
+ pkgver = r21.39e264f
+ pkgrel = 1
+ url = https://github.com/fevimu/cinnamon-applet-cpu-temperature
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = cinnamon
+ depends = lm_sensors
+ source = cinnamon-applet-cpu-temperatur-git::git+https://github.com/fevimu/cinnamon-applet-cpu-temperature.git
+ sha256sums = SKIP
+
+pkgname = cinnamon-applet-cpu-temperatur-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..514229f99783
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: nexttrex <jan@nexttrex.de>
+
+pkgname='cinnamon-applet-cpu-temperatur-git'
+pkgver=r21.39e264f
+pkgrel=1
+pkgdesc='Shows CPU Temperature on Cinnamon panel'
+arch=('any')
+url='https://github.com/fevimu/cinnamon-applet-cpu-temperature'
+license=('unknown')
+depends=('cinnamon' 'lm_sensors')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/fevimu/cinnamon-applet-cpu-temperature.git")
+sha256sums=('SKIP')
+_appletname='temperature@fevimu'
+_appletdir="usr/share/cinnamon/applets/$_appletname"
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname}"
+ install -dm755 "$pkgdir/$_appletdir"
+ find * -type f -exec install -Dm644 {} $pkgdir/$_appletdir/ \;
+}