summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorImperator Storm2021-11-04 10:37:00 +0100
committerTim Schumacher2021-11-04 22:12:46 +0100
commit38d2412a2b1e801504f6419a97029c490696b390 (patch)
treebcde32622ee6866dddef364ff5e6638821b3747c
parent56b523f432802826305e0ff32d60557d006f5361 (diff)
downloadaur-38d2412a2b1e801504f6419a97029c490696b390.tar.gz
Bring PKGBUILD in line with the submodule packaging guidelines
Co-Authored-By: Tim Schumacher <timschumi@gmx.de>
-rw-r--r--.SRCINFO44
-rw-r--r--.gitignore24
-rw-r--r--PKGBUILD65
3 files changed, 126 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7fbc3e28de9..1dc51389213a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = citra-git
pkgdesc = An experimental open-source Nintendo 3DS emulator/debugger
- pkgver = r9037.c40871f12
+ pkgver = r9079.5a7d80172
pkgrel = 1
url = https://github.com/citra-emu/citra/
arch = i686
@@ -15,7 +15,47 @@ pkgbase = citra-git
makedepends = qt5-multimedia
depends = ffmpeg
source = citra::git+https://github.com/citra-emu/citra
- md5sums = SKIP
+ source = boost::git+https://github.com/citra-emu/ext-boost/
+ source = catch::git+https://github.com/catchorg/Catch2
+ source = cpp-jwt::git+https://github.com/arun11299/cpp-jwt
+ source = cubeb::git+https://github.com/mozilla/cubeb
+ source = discord-rpc::git+https://github.com/discord/discord-rpc
+ source = dynarmic::git+https://github.com/citra-emu/dynarmic
+ source = enet::git+https://github.com/lsalzman/enet
+ source = fmt::git+https://github.com/fmtlib/fmt
+ source = libressl::git+https://github.com/citra-emu/ext-libressl-portable
+ source = nihistro::git+https://github.com/neobrain/nihstro
+ source = soundtouch::git+https://github.com/citra-emu/ext-soundtouch
+ source = teakra::git+https://github.com/wwylele/teakra
+ source = xbyak::git+https://github.com/herumi/xbyak
+ source = zstd::git+https://github.com/facebook/zstd
+ source = inih::git+https://github.com/benhoyt/inih
+ source = libusb::git+https://github.com/libusb/libusb
+ source = cryptopp::git+https://github.com/weidai11/cryptopp
+ source = lodepng::git+https://github.com/lvandeve/lodepng
+ source = sanitizers-cmake::git+https://github.com/arsenm/sanitizers-cmake
+ source = googletest::git+https://github.com/google/googletest
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = citra-git
depends = sdl2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a5146b171843
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,24 @@
+*.pkg.tar.*
+/boost/
+/catch/
+/citra/
+/cpp-jwt/
+/cryptopp/
+/cubeb/
+/discord-rpc/
+/dynarmic/
+/enet/
+/fmt/
+/googletest/
+/inih/
+/libressl/
+/libusb/
+/lodepng/
+/nihistro/
+/pkg/
+/sanitizers-cmake/
+/soundtouch/
+/src/
+/teakra/
+/xbyak/
+/zstd/
diff --git a/PKGBUILD b/PKGBUILD
index 76fb6a355781..5d7806982177 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Tim Schumacher <timschumi@gmx.de>
# Contributor: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
# Contributor: ceri
+# Contributor: Imperator Storm <30777770+ImperatorStorm@users.noreply.github.com>
_pkgbase='citra'
pkgbase="$_pkgbase-git"
pkgname=("$_pkgbase-git" "$_pkgbase-qt-git")
-pkgver=r9037.c40871f12
+pkgver=r9079.5a7d80172
pkgrel=1
pkgdesc="An experimental open-source Nintendo 3DS emulator/debugger"
arch=('i686' 'x86_64')
@@ -13,8 +14,48 @@ url="https://github.com/citra-emu/citra/"
license=('GPL2')
depends=('ffmpeg')
makedepends=('git' 'cmake' 'sdl2' 'qt5-base' 'shared-mime-info' 'desktop-file-utils' 'qt5-multimedia')
-source=("$_pkgbase::git+https://github.com/citra-emu/citra")
-md5sums=('SKIP')
+source=("$_pkgbase::git+https://github.com/citra-emu/citra"
+ "boost::git+https://github.com/citra-emu/ext-boost/"
+ "catch::git+https://github.com/catchorg/Catch2"
+ "cpp-jwt::git+https://github.com/arun11299/cpp-jwt"
+ "cubeb::git+https://github.com/mozilla/cubeb"
+ "discord-rpc::git+https://github.com/discord/discord-rpc"
+ "dynarmic::git+https://github.com/citra-emu/dynarmic"
+ "enet::git+https://github.com/lsalzman/enet"
+ "fmt::git+https://github.com/fmtlib/fmt"
+ "libressl::git+https://github.com/citra-emu/ext-libressl-portable"
+ "nihistro::git+https://github.com/neobrain/nihstro"
+ "soundtouch::git+https://github.com/citra-emu/ext-soundtouch"
+ "teakra::git+https://github.com/wwylele/teakra"
+ "xbyak::git+https://github.com/herumi/xbyak"
+ "zstd::git+https://github.com/facebook/zstd"
+ "inih::git+https://github.com/benhoyt/inih"
+ "libusb::git+https://github.com/libusb/libusb"
+ "cryptopp::git+https://github.com/weidai11/cryptopp"
+ "lodepng::git+https://github.com/lvandeve/lodepng"
+ "sanitizers-cmake::git+https://github.com/arsenm/sanitizers-cmake"
+ "googletest::git+https://github.com/google/googletest")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
# Clang generates weird object files when LTO is enabled, breaking static libraries (.a).
# Force-disable LTO if we are using clang.
@@ -29,10 +70,24 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgbase"
- mkdir -p build
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+
+ git submodule init
+ for external in boost catch cpp-jwt cubeb discord-rpc dynarmic enet fmt libressl nihistro soundtouch teakra xbyak zstd inih libusb cryptopp lodepng; do
+ git config submodule.$external.url "$srcdir/$external"
+ done
+ git submodule update
+
+ # agh, submodule has submodules
+ cd externals/cubeb
git submodule init
- git submodule update --init --recursive
+ git config submodule.cmake/sanitizers-cmake.url "$srcdir/sanitizers-cmake"
+ git config submodule.googletest.url "$srcdir/googletest"
+ git submodule update
}
build() {