summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2017-07-16 22:49:30 +0100
committerEmmanuel Gil Peyrot2017-07-16 22:49:30 +0100
commit502170a6da530d82ff20970eb241fe9341594056 (patch)
tree032bee744f8ebd1db5712b09b5b74344def8778c
parent4a0a24e4aa19307e3df4d109ddbdeb82502140bc (diff)
downloadaur-502170a6da530d82ff20970eb241fe9341594056.tar.gz
Add newer dependencies.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD17
2 files changed, 29 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 123720bd78ef..54b968842700 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Sep 13 04:34:58 UTC 2016
+# Sun Jul 16 21:48:51 UTC 2017
pkgbase = citra-git
pkgdesc = An experimental open-source Nintendo 3DS emulator/debugger
- pkgver = r3900.5cd3701
+ pkgver = r4916.e634b757
pkgrel = 1
url = https://github.com/citra-emu/citra/
arch = i686
@@ -19,6 +19,20 @@ pkgbase = citra-git
source = git+https://github.com/svn2github/inih
source = git+https://github.com/neobrain/nihstro
source = git+https://github.com/citra-emu/ext-soundtouch
+ source = git+https://github.com/philsquared/Catch
+ source = git+https://github.com/MerryMage/dynarmic
+ source = git+https://github.com/fmtlib/fmt
+ source = git+https://github.com/herumi/xbyak
+ source = git+https://github.com/whoshuu/cpr
+ source = git+https://github.com/lsalzman/enet
+ source = git+https://github.com/nlohmann/json
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 73344222c771..aa5c60b0aade 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgbase='citra'
pkgbase="$_pkgbase-git"
pkgname=("$_pkgbase-git" "$_pkgbase-qt-git")
-pkgver=r3918.8bf09b5
+pkgver=r4916.e634b757
pkgrel=1
pkgdesc="An experimental open-source Nintendo 3DS emulator/debugger"
arch=('i686' 'x86_64')
@@ -19,8 +19,11 @@ source=("$_pkgbase::git+https://github.com/citra-emu/citra"
'git+https://github.com/philsquared/Catch'
'git+https://github.com/MerryMage/dynarmic'
'git+https://github.com/fmtlib/fmt'
- 'git+https://github.com/herumi/xbyak')
-md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+ 'git+https://github.com/herumi/xbyak'
+ 'git+https://github.com/whoshuu/cpr'
+ 'git+https://github.com/lsalzman/enet'
+ 'git+https://github.com/nlohmann/json')
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/$_pkgbase"
@@ -38,6 +41,9 @@ prepare() {
git config submodule.soundtouch.url "$srcdir/ext-soundtouch"
git config submodule.catch.url "$srcdir/Catch"
git config submodule.dynarmic.url "$srcdir/dynarmic"
+ git config submodule.cpr.url "$srcdir/cpr"
+ git config submodule.enet.url "$srcdir/enet"
+ git config submodule.json.url "$srcdir/json"
git submodule update
cd externals/dynarmic
@@ -48,7 +54,10 @@ prepare() {
build() {
cd "$srcdir/$_pkgbase/build"
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_SYSTEM_CURL=ON
make
}