summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-07-05 01:13:38 -0700
committerHurricanePootis2023-07-05 01:13:38 -0700
commit8a67b445cdcbb357e8697020f5a35c27a860b97b (patch)
treec0056b17c85255c932e0ff29b130dfe916630513
parentcc0e8699a461cc539cf69c0075faee3567b984f4 (diff)
downloadaur-8a67b445cdcbb357e8697020f5a35c27a860b97b.tar.gz
Use external boost, update discord-rpc submodule
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 898bd49fad64..db38c3c3033c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = citra-git
pkgdesc = An experimental open-source Nintendo 3DS emulator/debugger
- pkgver = r9634.ca2d87e5e
+ pkgver = r9641.df9cc1b84
pkgrel = 1
url = https://github.com/citra-emu/citra/
arch = i686
@@ -12,14 +12,12 @@ pkgbase = citra-git
makedepends = doxygen
makedepends = rapidjson
makedepends = llvm
- makedepends = boost
makedepends = qt6-tools
makedepends = qt6-multimedia
makedepends = gcc
makedepends = glslang
depends = ffmpeg
depends = speexdsp
- depends = boost-libs
depends = mbedtls
depends = libusb
depends = openssl
@@ -43,7 +41,7 @@ pkgbase = citra-git
source = libressl::git+https://github.com/citra-emu/ext-libressl-portable.git
source = git+https://github.com/libusb/libusb.git
source = git+https://github.com/mozilla/cubeb
- source = git+https://github.com/discord/discord-rpc.git
+ source = git+https://github.com/yuzu-emu/discord-rpc.git
source = git+https://github.com/arun11299/cpp-jwt.git
source = git+https://github.com/wwylele/teakra.git
source = git+https://github.com/lvandeve/lodepng.git
@@ -100,7 +98,6 @@ pkgbase = citra-git
pkgname = citra-git
depends = ffmpeg
depends = speexdsp
- depends = boost-libs
depends = mbedtls
depends = libusb
depends = openssl
@@ -113,7 +110,6 @@ pkgname = citra-git
pkgname = citra-qt-git
depends = ffmpeg
depends = speexdsp
- depends = boost-libs
depends = mbedtls
depends = libusb
depends = openssl
diff --git a/PKGBUILD b/PKGBUILD
index 40f2a3ae7e87..5ec918c343ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgbase='citra'
pkgbase="$_pkgbase-git"
pkgname=("$_pkgbase-git" "$_pkgbase-qt-git")
-pkgver=r9634.ca2d87e5e
+pkgver=r9641.df9cc1b84
pkgrel=1
pkgdesc="An experimental open-source Nintendo 3DS emulator/debugger"
arch=('i686' 'x86_64')
@@ -24,8 +24,8 @@ else
_enable_lto=off
fi
license=('GPL2')
-depends=('ffmpeg' 'speexdsp' 'boost-libs' 'mbedtls' 'libusb' 'openssl' 'glibc' 'gcc-libs' 'libfdk-aac' 'sndio')
-makedepends=('git' 'cmake' 'python' 'doxygen' 'rapidjson' 'llvm' 'boost' 'qt6-tools' 'qt6-multimedia' 'gcc' 'glslang')
+depends=('ffmpeg' 'speexdsp' 'mbedtls' 'libusb' 'openssl' 'glibc' 'gcc-libs' 'libfdk-aac' 'sndio')
+makedepends=('git' 'cmake' 'python' 'doxygen' 'rapidjson' 'llvm' 'qt6-tools' 'qt6-multimedia' 'gcc' 'glslang')
source=("$_pkgbase::git+https://github.com/citra-emu/citra.git"
"boost::git+https://github.com/citra-emu/ext-boost.git"
"nihstro::git+https://github.com/neobrain/nihstro.git"
@@ -39,7 +39,7 @@ source=("$_pkgbase::git+https://github.com/citra-emu/citra.git"
"libressl::git+https://github.com/citra-emu/ext-libressl-portable.git"
"git+https://github.com/libusb/libusb.git"
"git+https://github.com/mozilla/cubeb"
- "git+https://github.com/discord/discord-rpc.git"
+ "git+https://github.com/yuzu-emu/discord-rpc.git"
"git+https://github.com/arun11299/cpp-jwt.git"
"git+https://github.com/wwylele/teakra.git"
"git+https://github.com/lvandeve/lodepng.git"
@@ -148,7 +148,7 @@ build() {
-DUSE_DISCORD_PRESENCE=ON \
-DENABLE_FFMPEG_VIDEO_DUMPER=ON \
-DENABLE_FFMPEG_AUDIO_DECODER=ON \
- -DUSE_SYSTEM_BOOST=ON \
+ -DUSE_SYSTEM_BOOST=OFF \
-DUSE_SYSTEM_SDL2=ON \
-DCMAKE_C_COMPILER=gcc \
-DCMAKE_CXX_COMPILER=g++ \