summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2017-12-06 10:57:35 +0100
committerEmmanuel Gil Peyrot2017-12-06 10:57:35 +0100
commitf407430010ff69917f9154a002e861f63f423d52 (patch)
tree428b73037ece3520a4d75ffb53f4d59d705db324
parent497b70f016a73f685116eab651138864bf52e6fa (diff)
downloadaur-f407430010ff69917f9154a002e861f63f423d52.tar.gz
Replace inih with its new upstream.
See https://github.com/citra-emu/citra/pull/3178
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD29
2 files changed, 29 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 332134dce6f7..28a1335c763c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Jul 18 17:33:42 UTC 2017
+# Wed Dec 6 09:47:40 UTC 2017
pkgbase = citra-git
pkgdesc = An experimental open-source Nintendo 3DS emulator/debugger
- pkgver = r4944.5621a650
+ pkgver = r5401.fcf0d104
pkgrel = 1
url = https://github.com/citra-emu/citra/
arch = i686
@@ -16,15 +16,17 @@ pkgbase = citra-git
makedepends = desktop-file-utils
source = citra::git+https://github.com/citra-emu/citra
source = git+https://github.com/citra-emu/ext-boost
- source = git+https://github.com/svn2github/inih
source = git+https://github.com/neobrain/nihstro
source = git+https://github.com/citra-emu/ext-soundtouch
source = git+https://github.com/philsquared/Catch
source = git+https://github.com/MerryMage/dynarmic
- source = git+https://github.com/fmtlib/fmt
source = git+https://github.com/herumi/xbyak
- source = git+https://github.com/whoshuu/cpr
+ source = git+https://github.com/weidai11/cryptopp
+ source = git+https://github.com/fmtlib/fmt
source = git+https://github.com/lsalzman/enet
+ source = git+https://github.com/whoshuu/cpr
+ source = git+https://github.com/benhoyt/inih
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1cc6cb3d866c..9ef9b6fbb218 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgbase='citra'
pkgbase="$_pkgbase-git"
pkgname=("$_pkgbase-git" "$_pkgbase-qt-git")
-pkgver=r4944.5621a650
+pkgver=r5442.e784434a
pkgrel=1
pkgdesc="An experimental open-source Nintendo 3DS emulator/debugger"
arch=('i686' 'x86_64')
@@ -13,16 +13,28 @@ license=('GPL2')
makedepends=('git' 'cmake' 'sdl2' 'qt5-base' 'shared-mime-info' 'desktop-file-utils')
source=("$_pkgbase::git+https://github.com/citra-emu/citra"
'git+https://github.com/citra-emu/ext-boost'
- 'git+https://github.com/svn2github/inih'
'git+https://github.com/neobrain/nihstro'
'git+https://github.com/citra-emu/ext-soundtouch'
'git+https://github.com/philsquared/Catch'
'git+https://github.com/MerryMage/dynarmic'
- 'git+https://github.com/fmtlib/fmt'
'git+https://github.com/herumi/xbyak'
+ 'git+https://github.com/weidai11/cryptopp'
+ 'git+https://github.com/fmtlib/fmt'
+ 'git+https://github.com/lsalzman/enet'
'git+https://github.com/whoshuu/cpr'
- 'git+https://github.com/lsalzman/enet')
-md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+ 'git+https://github.com/benhoyt/inih')
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd "$srcdir/$_pkgbase"
@@ -35,13 +47,16 @@ prepare() {
git submodule init
git config submodule.boost.url "$srcdir/ext-boost"
- git config submodule.inih.url "$srcdir/inih"
git config submodule.nihstro.url "$srcdir/nihstro"
git config submodule.soundtouch.url "$srcdir/ext-soundtouch"
git config submodule.catch.url "$srcdir/Catch"
git config submodule.dynarmic.url "$srcdir/dynarmic"
- git config submodule.cpr.url "$srcdir/cpr"
+ git config submodule.xbyak.url "$srcdir/xbyak"
+ git config submodule.cryptopp.url "$srcdir/cryptopp"
+ git config submodule.fmt.url "$srcdir/fmt"
git config submodule.enet.url "$srcdir/enet"
+ git config submodule.cpr.url "$srcdir/cpr"
+ git config submodule.inih.url "$srcdir/inih"
git submodule update
cd externals/dynarmic