summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaizhao Zhang2021-11-01 18:06:44 +0800
committerKaizhao Zhang2021-11-01 18:07:37 +0800
commit857a46cdb46583cc81364046cf46516cf4219e0f (patch)
tree69d33ee15a873d3e2ff7bfe81837261173009585
downloadaur-cjk-character-count.tar.gz
Initial import with version 0.15.1
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore5
-rw-r--r--CJK-character-count-en.desktop15
-rw-r--r--CJK-character-count-zhs.desktop15
-rw-r--r--CJK-character-count-zht.desktop15
-rw-r--r--PKGBUILD43
6 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03616ad01e7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = cjk-character-count
+ pkgdesc = Program that counts the amount of CJK characters based on Unicode ranges and Chinese encoding standards 字体汉字计数软件
+ pkgver = 0.15.1
+ pkgrel = 1
+ url = https://github.com/NightFurySL2001/CJK-character-count
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-fonttools
+ optdepends = python-pyglet: for Chinese (Traditional) version
+ options = !emptydirs
+ options = !strip
+ source = CJK-character-count-v0.15.1.tar.gz::https://github.com/NightFurySL2001/CJK-character-count/archive/v0.15.1.tar.gz
+ source = CJK-character-count-en.desktop
+ source = CJK-character-count-zhs.desktop
+ source = CJK-character-count-zht.desktop
+ sha256sums = 776e4a6d8467e9b667586d5d17c72b9ed350449e685986c479c1397c4addc68a
+ sha256sums = 867a30183690e88ce0da13fd7c51abd7a436540fee24deefc68ac4dc8d19fae6
+ sha256sums = 34301f6b1b4812d97ba74f42382437a5794e4d1334ebc0f4dd514278b7fde5d0
+ sha256sums = df70a15a2b93fb55521aa88f187eee20416d3923edaa6544502ce63891b17173
+
+pkgname = cjk-character-count
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..39467d77e101
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!*.desktop
diff --git a/CJK-character-count-en.desktop b/CJK-character-count-en.desktop
new file mode 100644
index 000000000000..a2c97b784ded
--- /dev/null
+++ b/CJK-character-count-en.desktop
@@ -0,0 +1,15 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name[zh_CN]=字体计数软件 (English version)
+Name=CJK character count (English version)
+GenericName[zh_CN]=字体计数软件 (English version)
+GenericName=CJK character count (English version)
+Comment[zh_CN]=以统一码(Unicode)区块与汉字编码标准统计字体内的汉字数量
+Comment=Program that counts the amount of CJK characters based on Unicode ranges and Chinese encoding standards
+# Translators: Do NOT translate or transliterate this text (this is an icon file name)!
+Icon=cjk-character-count
+Path=/usr/share/cjk-character-count
+Exec=python main.py
+Terminal=false
+Categories=Utility;
diff --git a/CJK-character-count-zhs.desktop b/CJK-character-count-zhs.desktop
new file mode 100644
index 000000000000..071b92fd058b
--- /dev/null
+++ b/CJK-character-count-zhs.desktop
@@ -0,0 +1,15 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name[zh_CN]=字体计数软件(简体中文版本)
+Name=CJK character count (Simplified Chinese version)
+GenericName[zh_CN]=字体计数软件(简体中文版本)
+GenericName=CJK character count (Simplified Chinese version)
+Comment[zh_CN]=以统一码(Unicode)区块与汉字编码标准统计字体内的汉字数量
+Comment=Program that counts the amount of CJK characters based on Unicode ranges and Chinese encoding standards
+# Translators: Do NOT translate or transliterate this text (this is an icon file name)!
+Icon=cjk-character-count
+Path=/usr/share/cjk-character-count
+Exec=python main-zhs.py
+Terminal=false
+Categories=Utility;
diff --git a/CJK-character-count-zht.desktop b/CJK-character-count-zht.desktop
new file mode 100644
index 000000000000..e7995cb017c6
--- /dev/null
+++ b/CJK-character-count-zht.desktop
@@ -0,0 +1,15 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name[zh_CN]=字体计数软件(繁体中文版本)
+Name=CJK character count (Traditional Chinese version)
+GenericName[zh_CN]=字体计数软件(繁体中文版本)
+GenericName=CJK character count (Traditional Chinese version)
+Comment[zh_CN]=以统一码(Unicode)区块与汉字编码标准统计字体内的汉字数量
+Comment=Program that counts the amount of CJK characters based on Unicode ranges and Chinese encoding standards
+# Translators: Do NOT translate or transliterate this text (this is an icon file name)!
+Icon=cjk-character-count
+Path=/usr/share/cjk-character-count
+Exec=python main-zht.py
+Terminal=false
+Categories=Utility;
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5193b87c5456
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
+
+_srcname=CJK-character-count
+
+pkgname=cjk-character-count
+pkgver=0.15.1
+pkgrel=1
+pkgdesc='Program that counts the amount of CJK characters based on Unicode ranges and Chinese encoding standards 字体汉字计数软件'
+arch=('any')
+url='https://github.com/NightFurySL2001/CJK-character-count'
+license=('MIT')
+depends=(
+ 'python'
+ 'python-fonttools'
+)
+optdepends=(
+ 'python-pyglet: for Chinese (Traditional) version'
+)
+options=(!emptydirs !strip)
+source=(
+ "${_srcname}-v${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
+ 'CJK-character-count-en.desktop'
+ 'CJK-character-count-zhs.desktop'
+ 'CJK-character-count-zht.desktop'
+)
+sha256sums=(
+ '776e4a6d8467e9b667586d5d17c72b9ed350449e685986c479c1397c4addc68a'
+ '867a30183690e88ce0da13fd7c51abd7a436540fee24deefc68ac4dc8d19fae6'
+ '34301f6b1b4812d97ba74f42382437a5794e4d1334ebc0f4dd514278b7fde5d0'
+ 'df70a15a2b93fb55521aa88f187eee20416d3923edaa6544502ce63891b17173'
+)
+
+package() {
+ install -d "${pkgdir}/usr/share"
+ cp -r "${_srcname}-${pkgver}" "${pkgdir}/usr/share/${pkgname}"
+ install -d "${pkgdir}/usr/share/pixmaps"
+ ln -s "/usr/share/${pkgname}/appicon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s "/usr/share/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 CJK-character-count-en.desktop "${pkgdir}/usr/share/applications/CJK-character-count-en.desktop"
+ install -Dm644 CJK-character-count-zhs.desktop "${pkgdir}/usr/share/applications/CJK-character-count-zhs.desktop"
+ install -Dm644 CJK-character-count-zht.desktop "${pkgdir}/usr/share/applications/CJK-character-count-zht.desktop"
+}