summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksii Vilchanskyi2018-05-01 11:02:08 +0200
committerOleksii Vilchanskyi2018-05-01 11:02:08 +0200
commit183cf8e348632456e6f81762d711c7eb425cfcc3 (patch)
treecb4a631b5fd42ec234333812bca2896dab17241c
parent67f6f8b72d8103f217ba788bc491c53812ae6b46 (diff)
downloadaur-183cf8e348632456e6f81762d711c7eb425cfcc3.tar.gz
Update to 0.3.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD32
-rwxr-xr-xckb-next.install17
3 files changed, 31 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 162e1c738607..66852000208a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ckb-next
pkgdesc = Corsair Keyboard and Mouse Input Driver, release version
- pkgver = 0.2.9
+ pkgver = 0.3.0
pkgrel = 1
url = https://github.com/mattanger/ckb-next
install = ckb-next.install
@@ -8,16 +8,16 @@ pkgbase = ckb-next
arch = x86_64
license = GPL2
makedepends = git
+ makedepends = cmake
depends = qt5-base
depends = hicolor-icon-theme
optdepends = libappindicator-gtk2: Ayatana indicators in Unity, KDE or Systray (GTK+ 2 library)
- optdepends = libappindicator-gtk3: Ayatana indicators in Unity, KDE or Systray (GTK+ 3 library)
provides = ckb-next
conflicts = ckb-git
conflicts = ckb-git-latest
conflicts = ckb-next
- source = https://github.com/ckb-next/ckb-next/archive/v0.2.9.tar.gz
- md5sums = 6e1da1f4ee5f1e9132f92ec7ad268499
+ source = https://github.com/ckb-next/ckb-next/archive/v0.3.0.tar.gz
+ md5sums = df3d0820f8f6a842bfe2a371adf4a60e
pkgname = ckb-next
diff --git a/PKGBUILD b/PKGBUILD
index b67b47ffbdeb..5a8d706e2bd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,33 @@
# Maintainer: Light2Yellow <oleksii.vilchanskyi@gmail.com>
pkgname=ckb-next
-pkgver=0.2.9
+pkgver=0.3.0
pkgrel=1
pkgdesc="Corsair Keyboard and Mouse Input Driver, release version"
arch=('i686' 'x86_64')
url="https://github.com/mattanger/ckb-next"
license=('GPL2')
depends=('qt5-base' 'hicolor-icon-theme')
-makedepends=('git')
-optdepends=('libappindicator-gtk2: Ayatana indicators in Unity, KDE or Systray (GTK+ 2 library)'
- 'libappindicator-gtk3: Ayatana indicators in Unity, KDE or Systray (GTK+ 3 library)')
+makedepends=('git' 'cmake')
+optdepends=('libappindicator-gtk2: Ayatana indicators in Unity, KDE or Systray (GTK+ 2 library)')
conflicts=('ckb-git' 'ckb-git-latest' 'ckb-next')
provides=('ckb-next')
install=ckb-next.install
source=("https://github.com/ckb-next/$pkgname/archive/v$pkgver.tar.gz")
-md5sums=('6e1da1f4ee5f1e9132f92ec7ad268499')
+md5sums=('df3d0820f8f6a842bfe2a371adf4a60e')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- ./qmake-auto
- make -j$(nproc --all)
+ cd "$srcdir/${pkgname}-${pkgver}"
+
+ cmake -H. -Bbuild \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_LIBEXECDIR="lib"
+ cmake --build build --target all
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- install -dm755 "$pkgdir/usr/bin"
- install -dm755 "$pkgdir/usr/lib/ckb-animations"
- install -Dm755 bin/ckb{,-daemon} "$pkgdir/usr/bin/"
- install -D bin/ckb-animations/* "$pkgdir/usr/lib/ckb-animations/"
-
- install -Dm644 usr/ckb.png "$pkgdir/usr/share/icons/hicolor/512x512/apps/ckb.png"
- install -Dm644 usr/ckb.desktop "$pkgdir/usr/share/applications/ckb.desktop"
+ cd "$srcdir/${pkgname}-${pkgver}"
- install -Dm644 service/systemd/ckb-daemon.service "$pkgdir/usr/lib/systemd/system/ckb-daemon.service"
- install -Dm644 udev/99-ckb-daemon.rules "$pkgdir/etc/udev/rules.d/99-ckb-daemon.rules"
+ DESTDIR="$pkgdir" cmake --build build --target install
}
diff --git a/ckb-next.install b/ckb-next.install
index 4581ce8b8352..31a836c80b4d 100755
--- a/ckb-next.install
+++ b/ckb-next.install
@@ -15,10 +15,10 @@ yellow="${bold}$(tput setaf 3)"
_as_service() {
cat << EOF
-You might want to run ckb-daemon as a systemd service:
+You might want to run ckb-next-daemon as a systemd service:
- systemctl enable ckb-daemon.service
- systemctl start ckb-daemon.service
+ systemctl enable ckb-next-daemon.service
+ systemctl start ckb-next-daemon.service
EOF
}
@@ -27,6 +27,7 @@ _terminate_gui_daemon() {
msg_blue "Terminating ckb-next GUI"
killall -TERM ckb 2>/dev/null
+ killall -TERM ckb-next 2>/dev/null
msg_blue "Terminating ckb-next daemon"
@@ -36,10 +37,20 @@ _terminate_gui_daemon() {
systemctl stop ckb-daemon.service
fi
+ running="$(systemctl is-active ckb-next-daemon.service)"
+ if [[ "$running" = "active" ]]; then
+ systemctl stop ckb-next-daemon.service
+ fi
+
running="$(systemctl is-enabled ckb-daemon.service)"
if [[ "$running" = "enabled" ]]; then
systemctl disable ckb-daemon.service
fi
+
+ running="$(systemctl is-enabled ckb-next-daemon.service)"
+ if [[ "$running" = "enabled" ]]; then
+ systemctl disable ckb-next-daemon.service
+ fi
}
# arg 1: the new package version