summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksii Vilchanskyi2017-06-28 02:50:47 +0200
committerOleksii Vilchanskyi2017-06-28 02:50:47 +0200
commit7cf725530788fa505a70b767a1f32c7e3112f42f (patch)
tree8b9955aeb97f704cd1eb42b9e6f829d9cf13c52b
downloadaur-7cf725530788fa505a70b767a1f32c7e3112f42f.tar.gz
First release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
-rwxr-xr-xckb-next.install28
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55ebdd776b25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ckb-next
+ pkgdesc = Corsair Keyboard and Mouse Input Driver, release version
+ pkgver = 0.2.8
+ pkgrel = 1
+ url = https://github.com/mattanger/ckb-next
+ install = ckb-next.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = qt5-base
+ depends = hicolor-icon-theme
+ conflicts = ckb-git
+ conflicts = ckb-git-latest
+ conflicts = ckb-next-git
+ conflicts = ckb-next-latest-git
+ source = https://github.com/mattanger/ckb-next/archive/v0.2.8.tar.gz
+ md5sums = bb2f354559fedc6883acc0a478e7e59a
+
+pkgname = ckb-next
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..317814303f3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Light2Yellow <alexvilchansky@yahoo.com>
+
+pkgname=ckb-next
+pkgver=0.2.8
+pkgrel=1
+pkgdesc="Corsair Keyboard and Mouse Input Driver, release version"
+arch=('i686' 'x86_64')
+url="https://github.com/mattanger/ckb-next"
+license=('GPL2')
+depends=('qt5-base' 'hicolor-icon-theme')
+makedepends=('git')
+conflicts=('ckb-git' 'ckb-git-latest' 'ckb-next-git' 'ckb-next-latest-git')
+install=ckb-next.install
+source=("https://github.com/mattanger/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('bb2f354559fedc6883acc0a478e7e59a')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./qmake-auto
+ make -j$(nproc --all)
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -dm755 "$pkgdir/usr/bin"
+ install -dm755 "$pkgdir/usr/lib/ckb-animations"
+ install -Dm755 bin/ckb{,-daemon} "$pkgdir/usr/bin/"
+ install -D bin/ckb-animations/* "$pkgdir/usr/lib/ckb-animations/"
+
+ install -Dm644 usr/ckb.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/ckb.png"
+ install -Dm644 usr/ckb.desktop "${pkgdir}/usr/share/applications/ckb.desktop"
+
+ install -Dm644 service/systemd/ckb-daemon.service "${pkgdir}/usr/lib/systemd/system/ckb-daemon.service"
+}
diff --git a/ckb-next.install b/ckb-next.install
new file mode 100755
index 000000000000..c82a406d0563
--- /dev/null
+++ b/ckb-next.install
@@ -0,0 +1,28 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ echo -e "=================================================="
+ note "To start the daemon automatically, you must execute:"
+ note "sudo systemctl start ckb-daemon"
+ note "sudo systemctl enable ckb-daemon"
+ echo -e '\n'
+ note "Further information:"
+ note "https://github.com/mattanger/ckb-next"
+ echo -e "=================================================="
+}
+
+post_upgrade() {
+ post_install
+}