summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDacoda Strack2017-02-27 23:02:53 -0800
committerDacoda Strack2017-02-27 23:02:53 -0800
commit4b76bc68a595ce7c60ca3a895313c755b1b2cdde (patch)
treede005b5819a231bb99367ffeb3f1c6355c9ec33e
downloadaur-cl-fad.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD50
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af763570836c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cl-fad
+ pkgdesc = A portable pathname library for Common Lisp
+ pkgver = 0.7.4
+ pkgrel = 1
+ url = http://weitz.de/cl-fad/
+ arch = any
+ license = custom:bsd-style
+ depends = sbcl
+ depends = cl-bordeaux-threads
+ depends = cl-alexandria
+ source = git+https://github.com/edicl/cl-fad.git#commit=56b0909150d54b2e3aaf2660735702b35558445d
+ md5sums = SKIP
+
+pkgname = cl-fad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bd2eacec825
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Dacoda Strack <dacoda.strack@gmail.com>
+
+pkgname=cl-fad
+pkgver=0.7.4
+pkgrel=1
+pkgdesc="A portable pathname library for Common Lisp"
+url="http://weitz.de/cl-fad/"
+arch=('any')
+license=('custom:bsd-style')
+depends=('sbcl' 'cl-bordeaux-threads' 'cl-alexandria')
+# makedepends=()
+# checkdepends=()
+# optdepends=()
+provides=()
+conflicts=()
+# replaces=()
+# backup=()
+# options=()
+# install=
+# changelog=
+source=("git+https://github.com/edicl/cl-fad.git#commit=56b0909150d54b2e3aaf2660735702b35558445d")
+# noextract=()
+md5sums=(SKIP)
+# validpgpkeys=()
+
+pkgver() {
+ cd ${pkgname}
+ echo $(cat CHANGELOG | head -n1 | sed -e 's/Version \(.*\)/\1/')
+}
+
+package() {
+ cd ${pkgname}
+
+ # install documentation
+ install -d ${pkgdir}/usr/share/doc/$pkgname/
+ install -m644 -t ${pkgdir}/usr/share/doc/$pkgname/ doc/*
+
+ # install sources
+ install -d ${pkgdir}/usr/share/common-lisp/source/${pkgname}
+ install -d ${pkgdir}/usr/share/common-lisp/systems
+
+ install -m 644 -t ${pkgdir}/usr/share/common-lisp/source/${pkgname} *.lisp
+ install -m 644 -t ${pkgdir}/usr/share/common-lisp/source/${pkgname} *.asd
+ install -m 644 -t ${pkgdir}/usr/share/common-lisp/source/${pkgname} *.system
+
+ # link asd files
+ cd ${pkgdir}/usr/share/common-lisp/systems
+ ln -s ../source/${pkgname}/*.asd .
+ ln -s ../source/${pkgname}/*.system .
+}