summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-05-16 04:16:54 +0000
committerGeorge Rawlinson2022-05-16 04:16:54 +0000
commit0c105d3a1f144ad2435a61be6b6ccd5167e3c6f6 (patch)
tree9f24d939c309aba5b7388a47b10e0bb9e95f6477
parentd6e62cfe6c6c49691caed2bc3f59cc3ab3c62b0d (diff)
downloadaur-cl-local-time.tar.gz
upgpkg: cl-local-time 1.0.6.r76-2
Add tests.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--run-tests.lisp7
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e4694e1e23c..a4f4117e73d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = cl-local-time
pkgdesc = Time manipulation library for Common Lisp
pkgver = 1.0.6.r76.ga177eb9
- pkgrel = 1
+ pkgrel = 2
url = https://local-time.common-lisp.dev/
arch = any
license = BSD
+ checkdepends = sbcl
+ checkdepends = cl-hu-dwim-stefil
makedepends = git
depends = common-lisp
depends = cl-asdf
depends = cl-fad
source = cl-local-time::git+https://github.com/dlowe-net/local-time#commit=a177eb911c0e8116e2bfceb79049265a884b701b
source = use-system-zoneinfo.patch
+ source = run-tests.lisp
b2sums = SKIP
b2sums = 216aa11cfd4e2ecb072d37f7d23aa5f369e376606ac5fd3846924902946ff3726893e87b26a339037b638673d2e15059956c4a71de84e86585e8569c4817a05a
+ b2sums = b26e1bb9b238ba1634dbbda3859f37bbe56497944d4a7d2a27e85700a4250a9756d2b2a2bb3f455dd3d2760d99338e49709c2ad533b74b4bb581f7ce592cf284
pkgname = cl-local-time
diff --git a/PKGBUILD b/PKGBUILD
index 78f615ddf04d..0861c69542c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,23 @@
pkgname=cl-local-time
_pkgname="${pkgname#cl-}"
pkgver=1.0.6.r76.ga177eb9
-pkgrel=1
+pkgrel=2
pkgdesc='Time manipulation library for Common Lisp'
arch=('any')
url='https://local-time.common-lisp.dev/'
license=('BSD')
depends=('common-lisp' 'cl-asdf' 'cl-fad')
makedepends=('git')
-#checkdepends=('cl-hu-dwim-stefil')
+checkdepends=('sbcl' 'cl-hu-dwim-stefil')
_commit='a177eb911c0e8116e2bfceb79049265a884b701b'
source=(
"$pkgname::git+https://github.com/dlowe-net/local-time#commit=$_commit"
'use-system-zoneinfo.patch'
+ 'run-tests.lisp'
)
b2sums=('SKIP'
- '216aa11cfd4e2ecb072d37f7d23aa5f369e376606ac5fd3846924902946ff3726893e87b26a339037b638673d2e15059956c4a71de84e86585e8569c4817a05a')
+ '216aa11cfd4e2ecb072d37f7d23aa5f369e376606ac5fd3846924902946ff3726893e87b26a339037b638673d2e15059956c4a71de84e86585e8569c4817a05a'
+ 'b26e1bb9b238ba1634dbbda3859f37bbe56497944d4a7d2a27e85700a4250a9756d2b2a2bb3f455dd3d2760d99338e49709c2ad533b74b4bb581f7ce592cf284')
pkgver() {
cd "$pkgname"
@@ -31,7 +33,13 @@ prepare() {
patch -p1 -i ../use-system-zoneinfo.patch
}
-# TODO cl-postgres & hu.dwim.stefil
+check() {
+ cd "$pkgname"
+
+ sbcl --script ../run-tests.lisp
+}
+
+# TODO cl-postgres integration
# TODO documentation
package() {
cd "$pkgname"
diff --git a/run-tests.lisp b/run-tests.lisp
new file mode 100644
index 000000000000..21a4c91ca387
--- /dev/null
+++ b/run-tests.lisp
@@ -0,0 +1,7 @@
+(require "asdf")
+
+(push (uiop/os:getcwd) asdf:*central-registry*)
+
+(asdf:load-system "local-time/test")
+
+(uiop:quit (if (asdf:test-system "local-time") 0 1))