summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Keenan2015-06-08 17:43:32 -0700
committerColin Keenan2015-06-08 17:43:32 -0700
commit11dcedf159e0eb20620f6d2afce9193c7ca09f0f (patch)
tree58dfa345477b986a12ea703127fb4bf24360a662
downloadaur-cla.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
-rw-r--r--cla.install23
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55ed94d2e490
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cla
+ pkgdesc = Close active window. If desktop is active, logout. For panel-launcher.
+ pkgver = 1.0
+ pkgrel = 3
+ url = https://github.com/colinkeenan/cla
+ install = cla.install
+ arch = any
+ license = GPL
+ depends = xdotool
+ depends = wmctrl
+ source = https://raw.githubusercontent.com/colinkeenan/cla/v1.0/cla
+ source = https://raw.githubusercontent.com/colinkeenan/cla/v1.0/cla.desktop
+ md5sums = 4aff89eb4505840fd11c83404cf33717
+ md5sums = c0c289e6dac69a28a82add518b0252ac
+
+pkgname = cla
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..665399889833
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Colin Keenan <colinnkeenan at gmail dot com>
+
+pkgname=cla
+pkgver=1.0
+pkgrel=3
+pkgdesc="Close active window. If desktop is active, logout. For panel-launcher."
+arch=('any')
+url="https://github.com/colinkeenan/cla"
+license=('GPL')
+depends=('xdotool' 'wmctrl')
+install=${pkgname}.install
+
+source=("https://raw.githubusercontent.com/colinkeenan/${pkgname}/v${pkgver}/${pkgname}"
+ "https://raw.githubusercontent.com/colinkeenan/${pkgname}/v${pkgver}/${pkgname}.desktop")
+md5sums=('4aff89eb4505840fd11c83404cf33717'
+ 'c0c289e6dac69a28a82add518b0252ac')
+
+package() {
+ install -D -m644 cla.desktop "$pkgdir/usr/share/applications/cla.desktop"
+ install -D -m755 cla "$pkgdir/usr/bin/cla"
+}
diff --git a/cla.install b/cla.install
new file mode 100644
index 000000000000..43267c3fb56a
--- /dev/null
+++ b/cla.install
@@ -0,0 +1,23 @@
+# Some colored makepkg-like functions
+msg_blue() {
+ printf "${BLUE}==>${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
+}
+
+note() {
+ printf "${BLUE}==>${ALL_OFF}${YELLOW} NOTE:${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
+}
+
+ALL_OFF="$(tput sgr0)"
+BOLD="$(tput bold)"
+BLUE="${BOLD}$(tput setaf 4)"
+YELLOW="${BOLD}$(tput setaf 3)"
+
+post_install() {
+ note "The script is named 'cla' and the desktop calls it 'Close Active'. This is meant to live on a panel in a launcher. Click to close the active window. Keep clicking until the desktop is active. Click again, and it will logout of the desktop."
+}
+
+
+post_upgrade() {
+ post_install
+}
+