summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Lane2015-06-12 16:31:43 +0100
committerJohn Lane2015-06-12 16:31:43 +0100
commitecb8f817baee9ddc8941632a22c9c0663b9ef9f6 (patch)
tree58f2bdecd56ff39de488cf4fd207c680ae44c966
parent45c618e40475cb1d4dc0ff7aa6a81c479be23725 (diff)
downloadaur-clamassassin.tar.gz
Patched to avoid email corruption when clamd not running
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD16
-rw-r--r--clamassassin-clamd.patch11
4 files changed, 31 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 432e55af8a9a..e8c23010358c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clamassassin
pkgdesc = A simple virus filter wrapper for ClamAV.
pkgver = 1.2.4
- pkgrel = 5
+ pkgrel = 6
url = http://jameslick.com/clamassassin/
arch = any
license = BSD
@@ -9,7 +9,9 @@ pkgbase = clamassassin
depends = clamav
depends = sh
source = http://jameslick.com/clamassassin/clamassassin-1.2.4.tar.gz
- md5sums = ce063e807ae29ab6666db9e01d01cc4c
+ source = clamassassin-clamd.patch
+ sha256sums = 63bae3963d27548d0fc7bbf76eb6bc5506291e9e1cb95aa13390497c4c17a100
+ sha256sums = 0904dccc934b86fbcde982e8ba21aeed2a1db8aeb6df1e2a6403358f161a6222
pkgname = clamassassin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8280e619950f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+clamassassin-*tar*
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
index 553bc8bf0e5b..b8665698779c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,28 @@
# Maintainer: John Lane <archlinux at jelmail dot com>
pkgname=clamassassin
pkgver=1.2.4
-pkgrel=5
+pkgrel=6
pkgdesc="A simple virus filter wrapper for ClamAV."
url="http://jameslick.com/clamassassin/"
arch=('any')
license=('BSD')
depends=('procmail' 'clamav' 'sh')
-source=(http://jameslick.com/clamassassin/clamassassin-${pkgver}.tar.gz)
-md5sums=('ce063e807ae29ab6666db9e01d01cc4c')
+source=(http://jameslick.com/clamassassin/clamassassin-${pkgver}.tar.gz
+ clamassassin-clamd.patch)
+sha256sums=('63bae3963d27548d0fc7bbf76eb6bc5506291e9e1cb95aa13390497c4c17a100'
+ '0904dccc934b86fbcde982e8ba21aeed2a1db8aeb6df1e2a6403358f161a6222')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
./configure --prefix=/usr --enable-clamdscan
+
+ # Clamassassin adds a header containing version information. When clamd isn't
+ # running, the clamdscan version output contains an error message making the
+ # text multi-line. This alters the body of the message which breaks base64
+ # message decoding. This patch fixes this (also reported upstream:
+ # http://lists.jameslick.com/pipermail/clamassassin-discuss/2015-June/000055.html)
+ patch < ../clamassassin-clamd.patch
+
make
}
package() {
diff --git a/clamassassin-clamd.patch b/clamassassin-clamd.patch
new file mode 100644
index 000000000000..8963ed09d06d
--- /dev/null
+++ b/clamassassin-clamd.patch
@@ -0,0 +1,11 @@
+--- clamassassin 2015-06-12 15:53:34.363051744 +0100
++++ clamassassin 2015-06-12 15:53:44.202174454 +0100
+@@ -132,7 +132,7 @@
+ bailiferr $?
+
+ # Set version header string
+-CLAMVERS=`${CLAMSCAN} -V --stdout`
++CLAMVERS=`${CLAMSCAN} -V --stdout | tail -1`
+
+ if [ ${ADDSCANNERFLAG} != 0 ]
+ then