summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgit user2024-01-18 23:31:06 +0100
committergit user2024-01-18 23:31:06 +0100
commitc171bb4f13cbac1191b9ca3063e2ce7624e26feb (patch)
tree4069af19b3467499de43482e5a7fde004360398d
parent4d5b5a99d1d8113a40838bfa658bf1bb7a2c0e5f (diff)
downloadaur-c171bb4f13cbac1191b9ca3063e2ce7624e26feb.tar.gz
Fixing `0002_protectedheaders.patch` so that it applies to the changed `AUTHORS` file.
-rw-r--r--.SRCINFO6
-rw-r--r--0002_protectedheaders.patch.AUTHORS.patch19
-rw-r--r--PKGBUILD8
3 files changed, 29 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bbdce619e14..427f7007c6bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = claws-mail-gtk2-git
pkgdesc = A GTK based e-mail client. Latest git checkout, built against 'gtk2'. Patched to use charset supersets to decode titles and to display protected headers.
pkgver = 3.20.0+35.r11746.20240112.76c8c420e
- pkgrel = 1
+ pkgrel = 2
epoch = 0
url = https://www.claws-mail.org/
arch = i686
@@ -99,10 +99,12 @@ pkgbase = claws-mail-gtk2-git
source = claws-mail::git://git.claws-mail.org/claws.git#branch=gtk2
source = 0001_encoding.diff::https://aur.archlinux.org/cgit/aur.git/plain/0001_encoding.diff?h=claws-mail-title-superset
source = 0002_protectedheaders.patch::https://www.thewildbeast.co.uk/claws-mail/bugzilla/attachment.cgi?id=2331
+ source = 0002_protectedheaders.patch.AUTHORS.patch
source = protectedheaders.patch.for-gtk2.patch
sha256sums = SKIP
sha256sums = 79e2b664d039f5cc0cf642359923e3d100ffc4ab070fc54c02d5792b624e26f6
- sha256sums = SKIP
+ sha256sums = 383f4ea03102ed2c8f19365b9bf2b757969d1617fcfd0a8375126f388cc60301
+ sha256sums = 1b505ea5396961e3c7fed5eb6478609644ba22324c3e4c03346aca017b095116
sha256sums = 3b1e568398950eb93d879353cfd6d49d81f7e1790c24972f36846f22ef4106cb
pkgname = claws-mail-gtk2-git
diff --git a/0002_protectedheaders.patch.AUTHORS.patch b/0002_protectedheaders.patch.AUTHORS.patch
new file mode 100644
index 000000000000..6903a3bb23cc
--- /dev/null
+++ b/0002_protectedheaders.patch.AUTHORS.patch
@@ -0,0 +1,19 @@
+--- 0002_protectedheaders.patch.orig 2024-01-18 23:25:38.953342794 +0100
++++ 0002_protectedheaders.patch 2024-01-18 23:25:59.603343088 +0100
+@@ -1,6 +1,5 @@
+-diff --git a/AUTHORS b/AUTHORS
+-index 5a7f0fed7..b32019aa5 100644
+---- a/AUTHORS
+-+++ b/AUTHORS
+-@@ -346,3 +346,4 @@ contributors (in addition to the above; based on Changelog)
++diff -ru claws-mail.orig/AUTHORS claws-mail.protectedheaders/AUTHORS
++--- claws-mail.orig/AUTHORS 2024-01-18 23:22:18.923340132 +0100
+++++ claws-mail.protectedheaders/AUTHORS 2024-01-18 23:24:32.633341919 +0100
++@@ -346,6 +346,7 @@
+ Viatrix
+@@ -9,2 +8,5 @@
+ + Holger Smolinski
++ Charles Huber
++ nycex
++ Gianni Ceccarelli
+ diff --git a/src/mimeview.c b/src/mimeview.c
diff --git a/PKGBUILD b/PKGBUILD
index 5531e03283f7..c59e8ac227cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,7 +29,7 @@ esac
pkgname="${_pkgname}-${_pkgvariant}-git"
epoch=0
pkgver=3.20.0+35.r11746.20240112.76c8c420e
-pkgrel=1
+pkgrel=2
pkgdesc="A GTK based e-mail client. Latest git checkout, built against '${_TOOLKIT}'. Patched to use charset supersets to decode titles and to display protected headers."
arch=(
'i686'
@@ -144,11 +144,13 @@ source=(
"${_pkgname}::git://git.claws-mail.org/claws.git#branch=${_gitbranch}"
"0001_encoding.diff::https://aur.archlinux.org/cgit/aur.git/plain/0001_encoding.diff?h=claws-mail-title-superset" ## NOTE!, if this gets removed, adapt the `provides` array and the `$pkgdesc`!
"0002_protectedheaders.patch::https://www.thewildbeast.co.uk/claws-mail/bugzilla/attachment.cgi?id=2331" ## NOTE!, if this gets removed, adapt the `provides` array and the `$pkgdesc`!
+ "0002_protectedheaders.patch.AUTHORS.patch" # Fixes `0002_protectedheaders.patch` so that it applies to the changed `AUTHORS` file.
)
sha256sums=(
'SKIP'
'79e2b664d039f5cc0cf642359923e3d100ffc4ab070fc54c02d5792b624e26f6'
- 'SKIP' # '383f4ea03102ed2c8f19365b9bf2b757969d1617fcfd0a8375126f388cc60301'
+ '383f4ea03102ed2c8f19365b9bf2b757969d1617fcfd0a8375126f388cc60301'
+ '1b505ea5396961e3c7fed5eb6478609644ba22324c3e4c03346aca017b095116'
)
if [ "${_TOOLKIT}" == "gtk2" ]; then
source+=("protectedheaders.patch.for-gtk2.patch")
@@ -185,6 +187,8 @@ fi
prepare() {
cd "${srcdir}/${_pkgname}"
+ patch -N --follow-symlinks -i "${srcdir}/0002_protectedheaders.patch.AUTHORS.patch" "${srcdir}/0002_protectedheaders.patch"
+
if [ "${_TOOLKIT}" == "gtk2" ]; then
msg2 "Patching '0002_protectedheaders.patch' for GTK2 ..."
patch -N --follow-symlinks -i "${srcdir}/protectedheaders.patch.for-gtk2.patch" -o "${srcdir}/0002_protectedheaders-${_TOOLKIT}.patch" "${srcdir}/0002_protectedheaders.patch"