summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJasper F2015-06-30 10:01:06 +0100
committerJasper F2015-06-30 10:01:06 +0100
commit1f22aee26e6e365d701f89e20d980ff8ed7effee (patch)
tree83532fb9967056fc3730a009357e4b8a20a6d3c1
downloadaur-cleanwad.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE36
-rw-r--r--Makefile.diff10
-rw-r--r--PKGBUILD29
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..556afe811668
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cleanwad
+ pkgdesc = An utility to clean Doom/Heretic/Hexen/Strife WAD files and sort directory entries by type
+ pkgver = 1.54
+ pkgrel = 3
+ url = http://www.martinhowe.net/gaming/downloads.php
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = unzip
+ source = http://www.martinhowe.net/gaming/public/cleanwad.zip
+ source = LICENSE
+ source = Makefile.diff
+ md5sums = a184a41c009c6f0c0ed16bbbba031069
+ md5sums = 50c924b20833a66b45a9fbf01049473d
+ md5sums = 51c57127c9fb8437a79ce3e500199daa
+
+pkgname = cleanwad
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..9240e6bfd913
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,36 @@
+The original permissions message was "You may use any part of this source
+file provided you give me credit.", so the original work of Serge Smirnov is
+hereby acknowledged - he put the hard work in when CleanWAD was first made.
+
+Authors MAY use the contents of this file as a base for modification or reuse
+provided that you e-mail the current author a copy and give them the right to
+use parts of your work in future releases. [The same ought really to be done for
+the original author of CleanWAD but he seems to have totally disappeared from
+the DOOM community]. You must also credit work of all previous authors and that
+of the original author, Serge Smirnov. Permissions have been obtained from
+original author for any of their resources modified or included in this file
+(he gave permission in the original source code provided he was credited).
+
+You MAY (and are encouraged to) distribute and use CleanWAD, provided:
+
+ (1) This entire collection of files is distributed UNMODIFIED,
+ preferably in the original ZIP file in which it should have come. I
+ have received permission from the original authors of any modified
+ or included content in this file to allow further distribution.
+ (2) The distribution is on a non-commercial basis; you may put CleanWAD
+ on FTP sites or CD or other media as part of a collection for which
+ you are charging a fee as long as you understand that the fee is for
+ the collecting and (if applicable) the media, *not* for CleanWAD.
+ (3) You accept that as with all free systems provided free of charge for
+ like-minded people,CleanWAD is NOT guaranteed to work completely or
+ correctly although it is likely to do so; thus it is a condition of
+ use that you accept that as with most such products, you use it at
+ your own risk. CleanWAD is **NOT** designed to be fault-tolerant!
+ (4) Any legal disputes over CleanWAD or any part of it, including these
+ terms and conditions, shall be governed by the Laws of England;
+ furthermore, you do not have permission to use CleanWAD in any
+ jurisdiction whose laws modify or limit these conditions unless you
+ VOLUNTARILY accept these conditions as if under the Laws of England.
+
+Note: although it won't happen straight away, once I have ensured that none of
+Serge Smirnov's original code is left, I will CONSIDER releasing it under GPL.
diff --git a/Makefile.diff b/Makefile.diff
new file mode 100644
index 000000000000..e14ff648b5d3
--- /dev/null
+++ b/Makefile.diff
@@ -0,0 +1,10 @@
+--- Makefile.orig 2008-07-19 20:48:29.000000000 +0200
++++ Makefile 2008-07-19 20:48:33.000000000 +0200
+@@ -1,6 +1,6 @@
+ # Linux Makefile for project cleanwad
+ SRCDIR=..
+-CFLAGS=-D__LINUX__ -g3
++CFLAGS+=-D__LINUX__
+ CC=cc
+ OBJS=\
+ wadopt.o \
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12d28fe9f644
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jasper Follas follasjj@live.co.uk
+
+pkgname=cleanwad
+pkgver=1.54
+pkgrel=3
+arch=('i686' 'x86_64')
+pkgdesc="An utility to clean Doom/Heretic/Hexen/Strife WAD files and sort directory entries by type"
+url="http://www.martinhowe.net/gaming/downloads.php"
+license=('custom')
+depends=('unzip')
+source=(http://www.martinhowe.net/gaming/public/${pkgname}.zip \
+ LICENSE \
+ Makefile.diff)
+md5sums=('a184a41c009c6f0c0ed16bbbba031069'
+ '50c924b20833a66b45a9fbf01049473d'
+ '51c57127c9fb8437a79ce3e500199daa')
+
+build() {
+ cd $srcdir
+ unzip -o sources.zip
+ cd linux
+ patch -Np0 -i $srcdir/Makefile.diff || return 1
+ make || return 1
+}
+
+package () {
+ install -m755 -D $srcdir/linux/cleanwad.exe $pkgdir/usr/bin/cleanwad
+ install -m644 -D $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}