summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Scheirer2019-12-18 12:53:19 -0500
committerMatt Scheirer2019-12-18 12:53:19 -0500
commit43dc9e14b2719575b0d05edc351d4680d1b163f1 (patch)
treef6aff68ef55c94956757aec0bf649c0c7a5cbe64
parentd5dcc5df28f5b77ee1882d2b61cba11ee1ac8ff6 (diff)
downloadaur-43dc9e14b2719575b0d05edc351d4680d1b163f1.tar.gz
Qt5 rewrite
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD43
2 files changed, 48 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38d9e189a444..88ab0062d9dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -46,3 +46,34 @@ pkgbase = clementine-git
pkgname = clementine-git
+pkgbase = clementine-git
+ pkgdesc = A modern music player and library organizer
+ pkgver = 1.3.1.r963.gfb51e7733
+ pkgrel = 1
+ url = http://www.clementine-player.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = cmake
+ makedepends = git
+ depends = crypto++
+ depends = chromaprint
+ depends = desktop-file-utils
+ depends = glew
+ depends = gst-plugins-base-libs
+ depends = libmygpo-qt5
+ depends = protobuf
+ depends = qt5-x11extras
+ optdepends = libcdio: for CD support
+ optdepends = libgpod: for iPhone and iPod Touch support
+ optdepends = liblastfm-qt5: for LastFM support
+ optdepends = libmtp: for MTP support
+ provides = clementine
+ conflicts = clementine
+ replaces = clementine-qt5-git
+ source = git+https://github.com/clementine-player/Clementine.git
+ sha256sums = SKIP
+
+pkgname = clementine-git
+
diff --git a/PKGBUILD b/PKGBUILD
index 2c0755a64eef..ec7feadc0e58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,50 +8,41 @@
# Based on community/clementine PKGBUILD
pkgname=clementine-git
-pkgver=1.3.1.r392.g83e860eab
+pkgver=1.3.1.r963.gfb51e7733
pkgrel=1
pkgdesc='A modern music player and library organizer'
url='http://www.clementine-player.org/'
license=('GPL')
arch=('i686' 'x86_64')
-depends=('chromaprint' 'crypto++' 'fftw' 'gcc-libs' 'glew' 'glib2' 'glibc'
- 'gst-plugins-base-libs' 'gstreamer' 'libcdio' 'libgl' 'libgpod'
- 'liblastfm' 'libmtp' 'libpulse' 'libx11' 'protobuf' 'qjson' 'qt4'
- 'sqlite' 'taglib' 'zlib')
-makedepends=('boost' 'cmake' 'mesa' 'sparsehash' 'git')
-optdepends=('gst-plugins-base: "Base" plugin libraries'
- 'gst-plugins-good: "Good" plugin libraries'
- 'gst-plugins-bad: "Bad" plugin libraries'
- 'gst-plugins-ugly: "Ugly" plugin libraries'
- 'gst-libav: Libav plugin'
- 'gvfs: Various devices support')
+depends=('crypto++' 'chromaprint' 'desktop-file-utils' 'glew' 'gst-plugins-base-libs' 'libmygpo-qt5' 'protobuf' 'qt5-x11extras')
+makedepends=('boost' 'cmake' 'git')
+optdepends=('libcdio: for CD support'
+ 'libgpod: for iPhone and iPod Touch support'
+ 'liblastfm-qt5: for LastFM support'
+ 'libmtp: for MTP support')
conflicts=('clementine')
provides=('clementine')
-source=("git+https://github.com/clementine-player/Clementine.git")
+replaces=('clementine-qt5-git')
+_name=Clementine
+source=("git+https://github.com/clementine-player/$_name.git")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/Clementine"
+ cd $srcdir/$_name
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$srcdir/Clementine"
-}
-
build() {
- mkdir -p "$srcdir/clementine-build"
- cd "$srcdir/clementine-build"
-
- cmake "$srcdir/Clementine" \
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+ cmake "$srcdir/$_name" \
-DCMAKE_BUILD_TYPE=Release \
- -DBUILD_WERROR=off \
- -DCMAKE_INSTALL_PREFIX="/usr"
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DENABLE_SPOTIFY_BLOB=off
make
}
package() {
- cd "$srcdir/clementine-build"
-
+ cd "$srcdir/build"
make DESTDIR="$pkgdir" install
}