summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzan2020-07-21 02:30:18 -0400
committerzan2020-07-21 02:30:18 -0400
commit83270b2ec2a87874c342fa631f30b302c9477552 (patch)
treee5a3264a176e787de554cf7a0a49166857f8e221
parent8c3b57453b61c08aade185d911597f4b23bb7815 (diff)
downloadaur-83270b2ec2a87874c342fa631f30b302c9477552.tar.gz
patch rev 2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--close-fix.diff28
3 files changed, 10 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c74c0e1a36f9..9c665a91d122 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -24,7 +24,7 @@ pkgbase = clementine-git
source = git+https://github.com/clementine-player/Clementine.git
source = close-fix.diff
sha256sums = SKIP
- sha256sums = 587c3724483825c2101fc15b8ef3b04b15a4dee34457285f94da6dd9b6db656c
+ sha256sums = f8db366cf61b956a96b21d587aff42f565d9ac84636d5188249b34268d3537c5
pkgname = clementine-git
diff --git a/PKGBUILD b/PKGBUILD
index 95a5be7109f8..6ecd7b0af5a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@ _name=Clementine
source=("git+https://github.com/clementine-player/$_name.git"
"close-fix.diff")
sha256sums=('SKIP'
- '587c3724483825c2101fc15b8ef3b04b15a4dee34457285f94da6dd9b6db656c')
+ 'f8db366cf61b956a96b21d587aff42f565d9ac84636d5188249b34268d3537c5')
pkgver() {
cd $_name
diff --git a/close-fix.diff b/close-fix.diff
index 2b931508c52f..4625d3e455cd 100644
--- a/close-fix.diff
+++ b/close-fix.diff
@@ -1,12 +1,11 @@
diff --git a/src/ui/mainwindow.cpp b/src/ui/mainwindow.cpp
-index 14921028c..a02f0548c 100644
+index 14921028c..4216e6237 100644
--- a/src/ui/mainwindow.cpp
+++ b/src/ui/mainwindow.cpp
-@@ -1443,20 +1443,6 @@ void MainWindow::StopAfterCurrent() {
- app_->playlist_manager()->active()->stop_after_current());
+@@ -1444,17 +1444,9 @@ void MainWindow::StopAfterCurrent() {
}
--void MainWindow::closeEvent(QCloseEvent* event) {
+ void MainWindow::closeEvent(QCloseEvent* event) {
- bool keep_running(false);
- if (tray_icon_)
- keep_running =
@@ -18,20 +17,9 @@ index 14921028c..a02f0548c 100644
- } else {
- Exit();
- }
--}
--
- void MainWindow::SetHiddenInTray(bool hidden) {
- settings_.setValue("hidden", hidden);
-
-diff --git a/src/ui/mainwindow.h b/src/ui/mainwindow.h
-index 5b2983bb4..756f33a47 100644
---- a/src/ui/mainwindow.h
-+++ b/src/ui/mainwindow.h
-@@ -134,7 +134,6 @@ class MainWindow : public QMainWindow, public PlatformInterface {
- void keyPressEvent(QKeyEvent* event);
- void changeEvent(QEvent*);
- void resizeEvent(QResizeEvent*);
-- void closeEvent(QCloseEvent* event);
++ if (!tray_icon_ || !tray_icon_->IsVisible())
++ Exit();
++ QMainWindow::closeEvent(event);
+ }
- #ifdef Q_OS_WIN32
- bool winEvent(MSG* message, long* result);
+ void MainWindow::SetHiddenInTray(bool hidden) {