summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMelanie Scheirer2023-07-16 12:29:24 -0400
committerMelanie Scheirer2023-07-16 12:30:18 -0400
commit9d0fd8f21c7cb58a1c20221a2bfc9bd4854d2342 (patch)
tree3a07d31195f19b41e3d597a868f35341f923003e
parenta101e27f8e634fd69901784c75792fbcd8347d9e (diff)
downloadaur-9d0fd8f21c7cb58a1c20221a2bfc9bd4854d2342.tar.gz
Update dependencies
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbf42a6d2676..a9c41474d1b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = clementine-git
pkgdesc = A modern music player and library organizer
- pkgver = 1.4.0rc1.r329.gf7bece3b8.0.gf7bece3b8
+ pkgver = 1.4.0rc1.r886.g6ff576863.0.g6ff576863
pkgrel = 1
url = http://www.clementine-player.org/
arch = x86_64
@@ -14,15 +14,16 @@ pkgbase = clementine-git
depends = libmygpo-qt5
depends = protobuf
depends = qt5-x11extras
- optdepends = libcdio: for CD support
- optdepends = libgpod: for iPhone and iPod Touch support
- optdepends = liblastfm-qt5: for LastFM support
- optdepends = libmtp: for MTP support
- optdepends = crypto++: for Spotify plugin
+ optdepends = fftw: moodbar support
+ optdepends = libcdio: Audio CD support
+ optdepends = libgpod: iPod and iPhone support
+ optdepends = liblastfm-qt5: LastFM support
+ optdepends = libmtp: MTP support
+ optdepends = sparsehash: Box, Dropbox, Google Drive, Seafile, Skydrive support
+ optdepends = qt5-tools: translations
provides = clementine
conflicts = clementine
source = git+https://github.com/clementine-player/Clementine.git
sha256sums = SKIP
pkgname = clementine-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4aa6fd4223ba..b2519326fcca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: zan <zan@420blaze.it>
+# Maintainer: zan <zan@nie.rs>
# Contributor: Jacob Henner <code@ventricle.us>
# Contributor: Eduardo Sánchez Muñoz
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
@@ -9,7 +9,7 @@
# Based on community/clementine PKGBUILD
pkgname=clementine-git
-pkgver=1.4.0rc1.r329.gf7bece3b8.0.gf7bece3b8
+pkgver=1.4.0rc1.r886.g6ff576863.0.g6ff576863
pkgrel=1
pkgdesc='A modern music player and library organizer'
url='http://www.clementine-player.org/'
@@ -17,11 +17,13 @@ license=(GPL)
arch=(x86_64)
depends=(chromaprint glew gst-plugins-base-libs libmygpo-qt5 protobuf qt5-x11extras)
makedepends=(boost cmake git)
-optdepends=('libcdio: for CD support'
- 'libgpod: for iPhone and iPod Touch support'
- 'liblastfm-qt5: for LastFM support'
- 'libmtp: for MTP support'
- 'crypto++: for Spotify plugin')
+optdepends=('fftw: moodbar support'
+ 'libcdio: Audio CD support'
+ 'libgpod: iPod and iPhone support'
+ 'liblastfm-qt5: LastFM support'
+ 'libmtp: MTP support'
+ 'sparsehash: Box, Dropbox, Google Drive, Seafile, Skydrive support'
+ 'qt5-tools: translations')
conflicts=(clementine)
provides=(clementine)
_name=Clementine
@@ -35,7 +37,6 @@ pkgver() {
build() {
cmake -B build -S $_name \
- -DENABLE_SPOTIFY_BLOB=off \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}