summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Sánchez Muñoz2016-09-15 23:53:14 +0200
committerEduardo Sánchez Muñoz2016-09-15 23:53:14 +0200
commited9a41770a74c272637275c3dce17976969dcd9d (patch)
tree41c9477d055ec37135355ec259aae3969e245ef0
parent9da71d88afcfd4bd9235dfaf939810cdf87785a4 (diff)
downloadaur-ed9a41770a74c272637275c3dce17976969dcd9d.tar.gz
Rewrite based on community/clementine.
-rw-r--r--.SRCINFO54
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD106
-rw-r--r--clementine.install13
4 files changed, 70 insertions, 107 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb8e1a229bf..71f7d7b8096 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,47 @@
+# Generated by mksrcinfo v8
+# Thu Sep 15 21:46:03 UTC 2016
pkgbase = clementine-git
- pkgdesc = A modern music player and library organiser and a port of Amarok 1.4, with some features rewritten to take advantage of Qt4.
- pkgver = 1.2.3.1109.g7cd4a56
+ pkgdesc = A modern music player and library organizer
+ pkgver = 1.3.1.r235.ge5ab3e7
pkgrel = 1
url = http://www.clementine-player.org/
- install = clementine.install
arch = i686
arch = x86_64
license = GPL
- makedepends = git
makedepends = boost
makedepends = cmake
makedepends = mesa
- depends = gst-plugins-base
- depends = taglib
+ makedepends = sparsehash
+ makedepends = git
+ depends = chromaprint
+ depends = crypto++
+ depends = fftw
+ depends = gcc-libs
depends = glew
- depends = liblastfm
+ depends = glib2
+ depends = glibc
+ depends = gst-plugins-base-libs
+ depends = gstreamer
+ depends = libcdio
+ depends = libechonest
+ depends = libgl
depends = libgpod
+ depends = liblastfm
depends = libmtp
- depends = libplist
- depends = hicolor-icon-theme
- depends = qt4
- depends = sparsehash
- depends = libechonest
- depends = qjson
- depends = libcdio
+ depends = libpulse
+ depends = libx11
depends = protobuf
- depends = crypto++
- depends = chromaprint
- depends = libmygpo-qt
- optdepends = gst-plugins-good: for use with "Good" plugin libraries
- optdepends = gst-plugins-bad: for use with "Bad" plugin libraries
- optdepends = gst-plugins-ugly: for use with "Ugly" plugin libraries
- provides = clementine
- conflicts = clementine
- replaces = clementine
+ depends = qjson
+ depends = qt4
+ depends = sqlite
+ depends = taglib
+ depends = zlib
+ optdepends = gst-plugins-base: "Base" plugin libraries
+ optdepends = gst-plugins-good: "Good" plugin libraries
+ optdepends = gst-plugins-bad: "Bad" plugin libraries
+ optdepends = gst-plugins-ugly: "Ugly" plugin libraries
+ optdepends = gst-libav: Libav plugin
+ optdepends = gvfs: Various devices support
source = git+https://github.com/clementine-player/Clementine.git
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 00000000000..8cd1abca106
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.tar.xz
+/Clementine
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
index 762e27bf7bf..3ccab49879d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,85 +1,49 @@
-# Mantainer: Adria Arrufat <swiftscythe@gmail.com>
-# Contributor: Ike Devolder <ike.devolder@gmail.com>
-# Contributor: Daniel Hill <daniel.hill@orcon.net.nz>
-# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+# Maintainer: Eduardo Sánchez Muñoz
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: BlackEagle <ike.devolder@gmail.com>
+# Contributor: Dany Martineau <dany.luc.martineau@gmail.com>
+
+# Based on community/clementine PKGBUILD
pkgname=clementine-git
-pkgver=1.2.3.1109.g7cd4a56
+pkgver=1.3.1.r235.ge5ab3e7
pkgrel=1
-pkgdesc="A modern music player and library organiser and a port of Amarok 1.4, with some features rewritten to take advantage of Qt4."
-arch=('i686' 'x86_64')
+pkgdesc='A modern music player and library organizer'
+url='http://www.clementine-player.org/'
license=('GPL')
-depends=('gst-plugins-base' 'taglib' 'glew' 'liblastfm' 'libgpod'
- 'libmtp' 'libplist' 'hicolor-icon-theme' 'qt4' 'sparsehash' 'libechonest'
- 'qjson' 'libcdio' 'protobuf' 'crypto++' 'chromaprint' 'libmygpo-qt')
-optdepends=('gst-plugins-good: for use with "Good" plugin libraries'
- 'gst-plugins-bad: for use with "Bad" plugin libraries'
- 'gst-plugins-ugly: for use with "Ugly" plugin libraries'
-)
-makedepends=('git' 'boost' 'cmake' 'mesa')
-install=clementine.install
-# Uncomment next lines to enable more features
-#makedepends+=('libspotify' 'libgpod' 'libimobiledevice')
-#optdepends+=(
-#'libspotify: for Spotify support'
-#'libgpod: for iPod support'
-#'libimobiledevice: for iPhone and iPod Touch support'
-#)
-
-url="http://www.clementine-player.org/"
-source=('git+https://github.com/clementine-player/Clementine.git')
+arch=('i686' 'x86_64')
+depends=('chromaprint' 'crypto++' 'fftw' 'gcc-libs' 'glew' 'glib2' 'glibc'
+ 'gst-plugins-base-libs' 'gstreamer' 'libcdio' 'libechonest' 'libgl'
+ 'libgpod' 'liblastfm' 'libmtp' 'libpulse' 'libx11' 'protobuf' 'qjson'
+ 'qt4' 'sqlite' 'taglib' 'zlib')
+makedepends=('boost' 'cmake' 'mesa' 'sparsehash' 'git')
+optdepends=('gst-plugins-base: "Base" plugin libraries'
+ 'gst-plugins-good: "Good" plugin libraries'
+ 'gst-plugins-bad: "Bad" plugin libraries'
+ 'gst-plugins-ugly: "Ugly" plugin libraries'
+ 'gst-libav: Libav plugin'
+ 'gvfs: Various devices support')
+source=("git+https://github.com/clementine-player/Clementine.git")
sha256sums=('SKIP')
-provides=('clementine')
-conflicts=('clementine')
-replaces=('clementine')
-
-
pkgver() {
- cd Clementine
- git describe | sed 's/^v//;s/-/./g;s/_/./g;'
-}
-
-prepare() {
- echo "Patching sources"
- sed -i 's/crypto++/cryptopp/g' ${srcdir}/Clementine/src/internet/spotify/spotifyblobdownloader.cpp
+ cd "$srcdir/Clementine"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- # rm -rf build
- mkdir -p build
- cd build
-
- cmake "../Clementine" \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ mkdir -p "$srcdir/clementine-build"
+ cd "$srcdir/clementine-build"
+
+ cmake "$srcdir/Clementine" \
-DCMAKE_BUILD_TYPE=Release \
- -DENABLE_VISUALISATIONS=OFF \
- -DENABLE_SPOTIFY_BLOB=OFF \
- -DENABLE_SKYDRIVE=OFF \
- -DENABLE_GOOGLE_DRIVE=OFF \
- -DENABLE_DROPBOX=OFF \
- -DENABLE_UBUNTU_ONE=OFF \
- -DENABLE_LIBGPOD=OFF \
- -DENABLE_WIIMOTEDEV=OFF \
- -DENABLE_SPARKLE=OFF \
- -DENABLE_LIBMTP=OFF \
- -DENABLE_GIO=ON \
- -DENABLE_BOX=OFF \
- -DLINGUAS="en"
-# -DENABLE_xxxx
-# - force their inclusion with =ON - this could trigger an error for
-# unlisted dependencies in depends=()
-# - remove them to get auto-detected - this could include (without notice)
-# packages not listed in depends=()
-
-# -DCMAKE_BUILD_TYPE remove to get a debug build with symbols
-# -DLINGUAS remove for all translations or put in a space-separated list
-# of translations to be included, eg. ="en es"
-# Qt doesn't respect LC_xxx settings... which is really annoying!
-make
+ -DCMAKE_INSTALL_PREFIX="/usr"
+ make
}
-package(){
- cd build
- make DESTDIR=${pkgdir} install
+package() {
+ cd "$srcdir/clementine-build"
+
+ make DESTDIR="$pkgdir" install
}
diff --git a/clementine.install b/clementine.install
deleted file mode 100644
index 2f0338d8aa6..00000000000
--- a/clementine.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install $1
-}
-
-
-post_remove() {
- post_install $1
-}