summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordpayne2015-12-26 23:03:31 -0800
committerdpayne2015-12-26 23:03:31 -0800
commite2ea16f67a2589308ca55938223949e3a7d4109c (patch)
tree98260670efc80fff715e99586cc97f047de3da7a
downloadaur-e2ea16f67a2589308ca55938223949e3a7d4109c.tar.gz
Adding initial files for cli visualizer
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
-rw-r--r--cli-visualizer.install4
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e77f59351af4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by dpayne
+# Thu Dec 26 11:57:02 UTC 2015
+pkgbase = cli-visualizer
+ pkgdesc = A cli visualizer for mpd
+ pkgver = 0.1
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/dpayne/cli-visualizer
+ install = cli-visualizer.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = pkg-config
+ depends = ncurses
+ depends = fftw
+ source = git+https://github.com/dpayne/cli-visualizer
+ md5sums = SKIP
+
+pkgname = cli-visualizer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a69664843c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: dpayne <darby.payne@gmail.com>
+# Maintainer: dpayne <darby.payne@gmail.com>
+
+pkgname="cli-visualizer"
+pkgver=0.1
+pkgrel=1
+epoch=1
+pkgdesc="A cli visualizer for mpd"
+arch=('i686' 'x86_64')
+url="https://github.com/dpayne/cli-visualizer"
+license=('MIT')
+depends=('ncurses' 'fftw')
+makedepends=('git' 'fftw' 'pkg-config')
+conflicts=()
+install=${pkgname}.install
+source=("git+https://github.com/dpayne/cli-visualizer")
+md5sums=('SKIP')
+
+pkgver() {
+ cd cli-visualizer || exit
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd cli-visualizer || exit
+ make
+}
+
+package() {
+ cd cli-visualizer || exit
+ make PREFIX="${pkgdir}/" install
+}
diff --git a/cli-visualizer.install b/cli-visualizer.install
new file mode 100644
index 000000000000..aab03971917f
--- /dev/null
+++ b/cli-visualizer.install
@@ -0,0 +1,4 @@
+post_upgrade() {
+}
+
+# vim:set ts=2 sw=2 et: