summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkmeaw2017-10-09 15:42:32 +0300
committerkmeaw2017-10-09 16:50:08 +0300
commitd9b4fc7bbc9fff64df4fc5f59fb5c34d1f6bd4bc (patch)
treef96efb22623c040820368026575e78b035f4e84b
parent0a9a0b6196eb2e03039443d461153d04d1ba90d9 (diff)
downloadaur-d9b4fc7bbc9fff64df4fc5f59fb5c34d1f6bd4bc.tar.gz
Bump to 54292
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--libunwind.patch10
3 files changed, 27 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c12fad8834e..32d21a8f7c5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = clickhouse
pkgdesc = An open-source column-oriented database management system that allows generating analytical data reports in real time
- pkgver = 1.1.54276
+ pkgver = 1.1.54292
pkgrel = 1
url = https://clickhouse.yandex/
install = clickhouse.install
@@ -16,12 +16,14 @@ pkgbase = clickhouse
backup = etc/clickhouse-client/config.xml
backup = etc/clickhouse-server/config.xml
backup = etc/clickhouse-server/users.xml
- source = https://github.com/yandex/ClickHouse/archive/v1.1.54276-stable.tar.gz
+ source = https://github.com/yandex/ClickHouse/archive/v1.1.54292-stable.tar.gz
source = clickhouse-server.service
source = re2-length.patch
- md5sums = 62f37ed7c09f2f11f277550d255e606f
+ source = libunwind.patch
+ md5sums = 68825ce6a1ef9842289d42c0f1015592
md5sums = f9f5663b0a9a58e99f481efe9d193e85
md5sums = 143f0146c3ef3a6832191fba352b70c4
+ md5sums = f3f60b75abf8d6f21de74db6e88e1e7b
pkgname = clickhouse
diff --git a/PKGBUILD b/PKGBUILD
index fdefdb097be8..44f0bff7900d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Dmitry Bilunov <kmeaw@yandex-team.ru>
pkgname=clickhouse
-pkgver=1.1.54276
+pkgver=1.1.54292
pkgrel=1
pkgdesc='An open-source column-oriented database management system that allows generating analytical data reports in real time'
arch=('i686' 'x86_64')
@@ -12,17 +12,24 @@ depends=('ncurses' 'readline' 'unixodbc' 'termcap')
makedepends=('poco' 'cmake')
source=(https://github.com/yandex/ClickHouse/archive/v$pkgver-stable.tar.gz
clickhouse-server.service
- re2-length.patch)
-md5sums=('62f37ed7c09f2f11f277550d255e606f'
+ re2-length.patch
+ libunwind.patch)
+md5sums=('68825ce6a1ef9842289d42c0f1015592'
'f9f5663b0a9a58e99f481efe9d193e85'
- '143f0146c3ef3a6832191fba352b70c4')
+ '143f0146c3ef3a6832191fba352b70c4'
+ 'f3f60b75abf8d6f21de74db6e88e1e7b')
backup=('etc/clickhouse-client/config.xml' 'etc/clickhouse-server/config.xml' 'etc/clickhouse-server/users.xml')
install=$pkgname.install
-build() {
+prepare() {
cd ClickHouse-$pkgver-stable
sed -e 's/mysqlxx common\(.*\) \(\${Z_LIB}\)/mysqlxx \2 common\1/' -i libs/libmysqlxx/CMakeLists.txt
patch -p1 < ../re2-length.patch
+ patch -p1 < ../libunwind.patch
+}
+
+build() {
+ cd ClickHouse-$pkgver-stable
cmake -D CMAKE_BUILD_TYPE:STRING=Release -D USE_STATIC_LIBRARIES:BOOL=False -D ENABLE_TESTS:BOOL=False -D UNBUNDLED:BOOL=False .
make clickhouse
}
diff --git a/libunwind.patch b/libunwind.patch
new file mode 100644
index 000000000000..fc79ecb7af15
--- /dev/null
+++ b/libunwind.patch
@@ -0,0 +1,10 @@
+--- a/contrib/libunwind/src/x86_64/Gos-linux.c 2017-10-09 14:13:11.126198905 +0300
++++ b/contrib/libunwind/src/x86_64/Gos-linux.c 2017-10-09 14:13:18.736311245 +0300
+@@ -29,6 +29,7 @@
+ #include "ucontext_i.h"
+
+ #include <sys/syscall.h>
++#include <asm-generic/ucontext.h>
+
+ HIDDEN void
+ tdep_fetch_frame (struct dwarf_cursor *dw, unw_word_t ip, int need_unwind_info)