summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchibald8692024-05-10 08:44:49 +0200
committerarchibald8692024-05-10 08:44:49 +0200
commit3b8babad49066faf5753409e0d3a537b92b7a335 (patch)
tree3648a17a531fab49b5afbd1771943c0398647ba5
parentab134f55da46559b614c4202170f981d7fcc841d (diff)
downloadaur-cling.tar.gz
Update to version 1.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD38
2 files changed, 18 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05ba7c656600..cbde6256d886 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = cling
pkgdesc = Interactive C++ interpreter, built on the top of LLVM and Clang libraries
- pkgver = 0.9
- pkgrel = 5
- url = https://root.cern.ch/cling
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://root.cern/cling/
arch = i686
arch = x86_64
license = custom:Cling Release License
@@ -18,10 +18,9 @@ pkgbase = cling
provides = cling
conflicts = cling
options = !lto
- source = cling-llvm::git+http://root.cern/git/llvm.git#tag=cling-v0.9
- source = cling-clang::git+http://root.cern/git/clang.git#tag=cling-v0.9
- source = cling::git+http://root.cern/git/cling.git#tag=v0.9
- sha256sums = SKIP
+ options = !debug
+ source = cling-llvm::git+https://github.com/root-project/llvm-project.git#tag=cling-llvm13-20240318-01
+ source = cling::git+https://github.com/root-project/cling.git#tag=v1.0
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ee1048c4f123..1022f1e59ad4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: archibald869 <archibald869 at web dot de>
pkgname=cling
-pkgver=0.9
-pkgrel=5
+pkgver=1.0
+pkgrel=1
pkgdesc="Interactive C++ interpreter, built on the top of LLVM and Clang libraries"
arch=("i686" "x86_64")
-url="https://root.cern.ch/cling"
+url="https://root.cern/cling/"
license=("custom:Cling Release License")
provides=("cling")
conflicts=("cling")
@@ -18,31 +18,15 @@ optdepends=(
"python-yaml: support for opt-viewer"
)
source=(
- "cling-llvm::git+http://root.cern/git/llvm.git#tag=cling-v$pkgver"
- "cling-clang::git+http://root.cern/git/clang.git#tag=cling-v$pkgver"
- "cling::git+http://root.cern/git/cling.git#tag=v$pkgver"
+ "cling-llvm::git+https://github.com/root-project/llvm-project.git#tag=cling-llvm13-20240318-01"
+ "cling::git+https://github.com/root-project/cling.git#tag=v$pkgver"
)
sha256sums=(
"SKIP"
"SKIP"
- "SKIP"
)
-options=('!lto')
-
-
-prepare() {
- if [ ! -h "$srcdir/cling-llvm/tools/clang" ]; then
- ln -s "$srcdir/cling-clang" "$srcdir/cling-llvm/tools/clang"
- fi
+options=(!lto !debug)
- if [ ! -h "$srcdir/cling-llvm/tools/cling" ]; then
- ln -s "$srcdir/cling" "$srcdir/cling-llvm/tools/cling"
- fi
-
- # patch missing header file
- sed -i '/^#include <vector>$/i #include <limits>' \
- "$srcdir/cling-llvm/utils/benchmark/src/benchmark_register.h"
-}
build() {
mkdir -p "$srcdir/build"
@@ -60,8 +44,10 @@ build() {
-DLLVM_BUILD_TOOLS=OFF \
-DLLVM_ENABLE_SPHINX=OFF \
-DLLVM_ENABLE_DOXYGEN=OFF \
- -DFFI_INCLUDE_DIR=$(pkg-config --cflags-only-I libffi | cut -c3-) \
- "$srcdir/cling-llvm"
+ -DLLVM_EXTERNAL_PROJECTS=cling \
+ -DLLVM_EXTERNAL_CLING_SOURCE_DIR="$srcdir/cling" \
+ -DLLVM_ENABLE_PROJECTS=clang \
+ "$srcdir/cling-llvm/llvm"
ninja
}
@@ -74,12 +60,12 @@ package() {
install -d "$pkgdir/usr/bin"
ln -s "/opt/cling/bin/cling" "$pkgdir/usr/bin/cling"
- install -Dm644 "$srcdir/cling-llvm/tools/cling/LICENSE.TXT" \
+ install -Dm644 "$srcdir/cling/LICENSE.TXT" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
# include CMake target import file so that other packages are able to use
# `find_package(Cling REQUIRED)`
- install -Dm644 "$srcdir/build/lib/cmake/cling/ClingTargets.cmake" \
+ install -Dm644 "$srcdir/build/tools/cling/lib/cmake/cling/ClingTargets.cmake" \
"$pkgdir/opt/cling/lib/cmake/cling"
# adjust cling target locations