summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Flierl2015-06-09 15:45:04 +0200
committerAlex Flierl2015-06-09 15:45:04 +0200
commitcd8868b54dac886fd28bbd371fd9e4fd5bf430bf (patch)
treeb805a43053bb8fbf5bd0e29700766669a51828d0
downloadaur-clonk_rage.tar.gz
Initial import
-rw-r--r--.SRCINFO32
-rw-r--r--ChangeLog11
-rw-r--r--PKGBUILD81
-rw-r--r--clonk_rage.desktop11
-rw-r--r--clonk_rage.install19
-rw-r--r--clonk_rage.sh9
-rw-r--r--de_clonk.xml58
7 files changed, 221 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84bc1bf5f80c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = clonk_rage
+ pkgdesc = An entertaining, action-packed game of strategy, tactics, and skill.
+ pkgver = 4.9.10.7
+ pkgrel = 1
+ url = http://clonk.de
+ install = clonk_rage.install
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = ISC
+ license = CCPL:by-nc
+ license = custom:trademark
+ depends = glu
+ depends = libxpm
+ depends = sdl_mixer
+ depends = gtk2
+ depends = libpng12
+ depends = libjpeg6-turbo
+ depends = desktop-file-utils
+ depends = timidity++
+ source = http://www.clonkx.de/rage/cr_full_linux.tar.bz2
+ source = clonk_rage.desktop
+ source = de_clonk.xml
+ source = clonk_rage.sh
+ md5sums = a8bb948f02ac9d7950266c2ffbb7692a
+ md5sums = fca7370f1e9cb612edfc90b0f7d9d5ed
+ md5sums = 56b7e0903752a933a94dd3038b50fc56
+ md5sums = bbeed581309eac14697d030f6ac295ab
+
+pkgname = clonk_rage
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..c881b717b673
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,11 @@
+2014-05-06 shad0w73 <shad0w73@maills.de>
+
+ * 4.9.10.7-1 :
+ added ChangeLog.
+ new upstream release.
+ Changed licenses.
+ Updated dependencies.
+ Moved new licenses to /usr/share/licenses/clonk_rage/.
+
+ * clonk_rage.install :
+ Removed license/register notification
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8790196a7297
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# Maintainer: shad0w73 <shad0w73@maills.de>
+# Contributor: suppaman2 <suppaman2@gmail.com>
+#
+
+pkgname=clonk_rage
+_orig=cr_full_linux
+pkgver=4.9.10.7
+pkgrel=1
+pkgdesc="An entertaining, action-packed game of strategy, tactics, and skill."
+arch=('i686' 'x86_64')
+url="http://clonk.de"
+license=('ISC' 'CCPL:by-nc' 'custom:trademark')
+groups=('games')
+md5sums=('a8bb948f02ac9d7950266c2ffbb7692a'
+ 'fca7370f1e9cb612edfc90b0f7d9d5ed'
+ '56b7e0903752a933a94dd3038b50fc56'
+ 'bbeed581309eac14697d030f6ac295ab')
+install=${pkgname}.install
+changelog=ChangeLog
+
+depends=('glu' 'libxpm' 'sdl_mixer' 'gtk2' 'libpng12'
+ 'libjpeg6-turbo' 'desktop-file-utils' 'timidity++')
+
+source=("http://www.clonkx.de/rage/cr_full_linux.tar.bz2" \
+ "clonk_rage.desktop" \
+ "de_clonk.xml" \
+ "clonk_rage.sh")
+
+package() {
+
+ # remove unneeded files
+ rm "$srcdir"/$_orig/install.sh
+ rm "$srcdir"/$_orig/uninstall.sh
+ rm "$srcdir"/$_orig/OpenSSL.txt
+ rm "$srcdir"/$_orig/LGPL.txt
+
+ # create directories
+ install -d "$pkgdir"/usr/share/licenses/clonk_rage
+ install -d "$pkgdir"/usr/share/icons/hicolor/48x48/mimetypes
+ install -d "$pkgdir"/opt
+
+ # install licenses
+ install -Dm644 "$srcdir"/$_orig/clonk_{content,trademark}_license.txt "$pkgdir"/usr/share/licenses/clonk_rage/
+ rm "$srcdir"/$_orig/clonk_{content,trademark}_license.txt
+
+ # install icons
+ install -Dm644 "$srcdir"/$_orig/icons/cr.png "$pkgdir"/usr/share/icons/hicolor/48x48/apps/clonk_rage.png
+ install -Dm644 "$srcdir"/$_orig/icons/c4{d,f,g,k,p,s,u}.png "$pkgdir"/usr/share/icons/hicolor/48x48/mimetypes/
+
+ # choose binaries
+ if [ "$CARCH" == "x86_64" ]; then
+ mv -f "$srcdir"/$_orig/clonk64 "$srcdir"/$_orig/clonk
+ mv -f "$srcdir"/$_orig/c4group64 "$srcdir"/$_orig/c4group
+ else
+ rm "$srcdir"/$_orig/clonk64
+ rm "$srcdir"/$_orig/c4group64
+ fi
+
+ # move everything else (its about 100mb, so moving saves a lot of resources)
+ rm -R "$srcdir"/$_orig/icons
+ mv "$srcdir"/$_orig "$pkgdir"/opt/$pkgname
+ chgrp -R games "$pkgdir"/opt/$pkgname
+ chmod -R g+w "$pkgdir"/opt/$pkgname
+
+ # chmod exec's
+ chmod 774 "$pkgdir"/opt/$pkgname/clonk
+ chmod 774 "$pkgdir"/opt/$pkgname/c4group
+
+ # launch script
+ install -Dm755 "$srcdir"/clonk_rage.sh "$pkgdir"/usr/bin/clonk_rage
+
+ # c4group link
+ ln -s /opt/clonk_rage/c4group "$pkgdir"/usr/bin/
+
+ # desktop launcher
+ install -Dm644 "$srcdir"/clonk_rage.desktop "$pkgdir"/usr/share/applications/clonk_rage.desktop
+
+ # mime types
+ install -Dm644 "$srcdir"/de_clonk.xml "$pkgdir"/usr/share/mime/packages/clonk_rage.xml
+
+}
diff --git a/clonk_rage.desktop b/clonk_rage.desktop
new file mode 100644
index 000000000000..496557dc7397
--- /dev/null
+++ b/clonk_rage.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Clonk Rage
+Type=Application
+Comment=An entertaining, action-packed game of strategy, tactics, and skill.
+Icon=clonk_rage
+Categories=Game;ActionGame;
+MimeType=application/x-vnd.clonk.c4key;application/vnd.clonk.c4group
+StartupNotify=true
+StartupWMClass=Clonk Rage
+Exec=clonk_rage
+Terminal=false
diff --git a/clonk_rage.install b/clonk_rage.install
new file mode 100644
index 000000000000..7e7a6df42bac
--- /dev/null
+++ b/clonk_rage.install
@@ -0,0 +1,19 @@
+post_install() {
+ echo gtk-update-icon-cache ...
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ echo update-mime-database ...
+ update-mime-database /usr/share/mime &> /dev/null
+ echo update-desktop-database ...
+ update-desktop-database -q
+
+ echo ''
+ echo 'Notes:'
+ echo ''
+ echo 'You can use the game's own update function instead of updating the package.'
+ echo ''
+ echo 'IMPORTANT:'
+ echo ''
+ echo 'Make sure that all users who want to play Clonk Rage are in the group games!'
+ echo ''
+
+}
diff --git a/clonk_rage.sh b/clonk_rage.sh
new file mode 100644
index 000000000000..9e57ac0be85e
--- /dev/null
+++ b/clonk_rage.sh
@@ -0,0 +1,9 @@
+#!/bin/bash
+/opt/clonk_rage/clonk $*
+
+if [ $? == 126 ]; then
+ message="You must be in the group 'games' to play Clonk Rage."
+ zenity --info --text "${message}" ||
+ kdialog --msgbox "${message}" ||
+ xmessage -buttons okay -default okay "${message}"
+fi
diff --git a/de_clonk.xml b/de_clonk.xml
new file mode 100644
index 000000000000..c78ffc201f34
--- /dev/null
+++ b/de_clonk.xml
@@ -0,0 +1,58 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/vnd.clonk.c4game">
+ <alias type="application/vnd.clonk.c4group" />
+ <comment>Clonk 4 System file</comment>
+ <comment xml:lang="de">Clonk 4 Systemdatei</comment>
+ <glob pattern="*.c4g" />
+ <icon name="c4g" />
+ </mime-type>
+
+ <mime-type type="application/vnd.clonk.c4definition">
+ <alias type="application/vnd.clonk.c4group" />
+ <comment>Clonk 4 Object definition</comment>
+ <comment xml:lang="de">Clonk 4 Objektdefinition</comment>
+ <glob pattern="*.c4d" />
+ <icon name="c4d" />
+ </mime-type>
+
+ <mime-type type="application/vnd.clonk.c4folder">
+ <alias type="application/vnd.clonk.c4group" />
+ <comment>Clonk 4 Scenario folder</comment>
+ <comment xml:lang="de">Clonk 4 Szenarienordner</comment>
+ <glob pattern="*.c4f" />
+ <icon name="c4f" />
+ </mime-type>
+
+ <mime-type type="application/vnd.clonk.c4player">
+ <alias type="application/vnd.clonk.c4group" />
+ <comment>Clonk 4 Player</comment>
+ <comment xml:lang="de">Clonk 4 Spieler</comment>
+ <glob pattern="*.c4p" />
+ <icon name="c4p" />
+ </mime-type>
+
+ <mime-type type="application/vnd.clonk.c4update">
+ <alias type="application/vnd.clonk.c4group" />
+ <comment>Clonk 4 Update</comment>
+ <comment xml:lang="de">Clonk 4 Update</comment>
+ <glob pattern="*.c4u" />
+ <icon name="c4u" />
+ </mime-type>
+
+ <mime-type type="application/vnd.clonk.c4scenario">
+ <alias type="application/vnd.clonk.c4group" />
+ <comment>Clonk 4 Scenario</comment>
+ <comment xml:lang="de">Clonk 4 Szenario</comment>
+ <glob pattern="*.c4s" />
+ <icon name="c4s" />
+ </mime-type>
+
+ <mime-type type="application/x-vnd.clonk.c4key">
+ <sub-class-of type="text/plain"/>
+ <comment>Clonk Registration key</comment>
+ <comment xml:lang="de">Clonk Registrierungsschlüssel</comment>
+ <glob pattern="*.c4k" />
+ <icon name="c4k" />
+ </mime-type>
+</mime-info>