summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Mueller2015-03-03 21:28:18 +0100
committerAaron Mueller2015-03-03 21:28:18 +0100
commit35bb77fcfb663ac4368198721aa436a6fdcf1ffd (patch)
tree8676328380d7e6c00463b11f05e0da03b9ea912d
parentb1087d574d9c7e1f61917d34bc814a22fb557a78 (diff)
downloadaur-35bb77fcfb663ac4368198721aa436a6fdcf1ffd.tar.gz
Fix the multithreaded compiling on cloog
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bce5cc9b776d..29e4660f69f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = cloog
pkgdesc = Library that generates loops for scanning polyhedra
pkgver = 0.18.3
- pkgrel = 2
+ pkgrel = 3
url = http://www.bastoul.net/cloog/
arch = i686
arch = x86_64
license = GPL
- depends = isl
+ depends = isl>=0.14
source = http://www.bastoul.net/cloog/pages/download/cloog-0.18.3.tar.gz
md5sums = 3ded42bb87022981abccd42466a00b65
diff --git a/PKGBUILD b/PKGBUILD
index a5022f003606..a6adf38c02bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=cloog
pkgver=0.18.3
-pkgrel=2
+pkgrel=3
pkgdesc="Library that generates loops for scanning polyhedra"
arch=('i686' 'x86_64')
url="http://www.bastoul.net/cloog/"
license=('GPL')
-depends=('isl')
+depends=('isl>=0.14')
source=(http://www.bastoul.net/cloog/pages/download/$pkgname-$pkgver.tar.gz)
md5sums=('3ded42bb87022981abccd42466a00b65')
@@ -20,16 +20,15 @@ build() {
cd $srcdir/$pkgname-$pkgver
./configure --prefix=/usr --with-isl=system
- # There are certain race conditions on running the tests, so we restrict the
- # compilation to one job (one CPU core).
- MAKEFLAGS=-j1
-
make
}
check() {
cd $srcdir/$pkgname-$pkgver
- make check
+
+ # There are certain race conditions on running the tests, so we restrict
+ # it to one job (one CPU core).
+ make -j1 check
}
package() {