summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormuhviehstah2016-11-27 07:20:13 +0100
committermuhviehstah2016-11-27 07:20:13 +0100
commit908f3c8cda173afcbaf99eb749c50396aa59fd36 (patch)
treebb407fbb075ab5c686952b3c1be1a91e51a7f028
downloadaur-cloog-isl14.tar.gz
initial
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a63ce001f29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cloog-isl14
+ pkgdesc = Library that generates loops for scanning polyhedra
+ pkgver = 0.18.4
+ pkgrel = 2
+ url = http://www.bastoul.net/cloog/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL
+ depends = isl14
+ source = http://www.bastoul.net/cloog/pages/download/cloog-0.18.4.tar.gz
+ md5sums = e531f725244856c92c9bba009ff44faf
+
+pkgname = cloog-isl14
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f648291f7ffe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Aaron Fischer <mail@aaron-fischer.net>
+# Contributor: Allan McRae <allan@archlinux.org>
+
+pkgname=cloog-isl14
+_origpkgname=cloog
+pkgver=0.18.4
+pkgrel=2
+pkgdesc="Library that generates loops for scanning polyhedra"
+arch=('i686' 'x86_64' 'armv7h')
+url="http://www.bastoul.net/cloog/"
+license=('GPL')
+depends=('isl14')
+source=(http://www.bastoul.net/cloog/pages/download/$_origpkgname-$pkgver.tar.gz)
+md5sums=('e531f725244856c92c9bba009ff44faf')
+
+build() {
+ cd "${srcdir}/${_origpkgname}-${pkgver}"
+ ./configure --prefix=/usr --with-isl=system
+ make
+}
+
+check() {
+ cd "${srcdir}/${_origpkgname}-${pkgver}"
+ # There are certain race conditions on running the tests, so we restrict
+ # it to one job (one CPU core).
+ make -j1 check
+}
+
+package() {
+ cd "${srcdir}/${_origpkgname}-${pkgver}"
+ make DESTDIR=$pkgdir/ install
+}