summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-12-09 14:38:23 +0100
committerbartus2021-12-09 14:38:23 +0100
commit516d2d184e3ed0bdd6239b9931352ef2f9c52d90 (patch)
treedc7988683cf549bd151245fe073f8a3f31d6d110
parenta000b644a577db20f56a7e05f266a6839722e61b (diff)
downloadaur-516d2d184e3ed0bdd6239b9931352ef2f9c52d90.tar.gz
Drop upstream applied patches
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--cork.patch66
3 files changed, 0 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c650b20a549..187981b72f6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -38,7 +38,6 @@ pkgbase = cloudcompare-git
options = !strip
source = cloudcompare::git+https://github.com/CloudCompare/CloudCompare.git
source = cloudcompare-cork::git+https://github.com/CloudCompare/cork.git
- source = cork.patch
source = CloudCompare.desktop
source = ccViewer.desktop
source = libE57Format::git+https://github.com/asmaloney/libE57Format
@@ -51,7 +50,6 @@ pkgbase = cloudcompare-git
source = dlib::git+https://github.com/davisking/dlib
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 1789d726d65478857633fa4797da7c3ea4c13d90cdcc169d4197c58d2d33f123
sha256sums = 14096df9cf7aca3099d5df1585d1cf669544e9b10754dce3d2507100dd7034fe
sha256sums = 821ac2540e1196774e26f8033946ce7b36223dae7a2a7c78f4a901b4177f68cc
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a8c940488c4e..a974b95d96c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,13 +20,11 @@ conflicts=('cloudcompare')
provides=('cloudcompare')
source=("${name}::git+https://github.com/CloudCompare/CloudCompare.git${_fragment}"
"${name}-cork::git+https://github.com/CloudCompare/cork.git"
- cork.patch
CloudCompare.desktop
ccViewer.desktop
)
sha256sums=('SKIP'
'SKIP'
- '1789d726d65478857633fa4797da7c3ea4c13d90cdcc169d4197c58d2d33f123'
'14096df9cf7aca3099d5df1585d1cf669544e9b10754dce3d2507100dd7034fe'
'821ac2540e1196774e26f8033946ce7b36223dae7a2a7c78f4a901b4177f68cc'
'SKIP'
@@ -40,7 +38,6 @@ sha256sums=('SKIP'
prepare() {
prepare_submodule
- git -C "${srcdir}/${name}-cork" apply -v "${srcdir}"/cork.patch
#fix gcc:11 porting
sed '1 i\#include <limits>' -i "${srcdir}/${name}"/plugins/core/IO/qE57IO/extern/libE57Format/src/E57XmlParser.cpp
}
diff --git a/cork.patch b/cork.patch
deleted file mode 100644
index 904c37c3abbf..000000000000
--- a/cork.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff --git a/Makefile b/Makefile
-index a9fbb62..8ca986c 100644
---- a/Makefile
-+++ b/Makefile
-@@ -62,7 +62,7 @@ INC := $(INC) $(GMPINC)
- # use the second line to disable profiling instrumentation
- # PROFILING := -pg
- PROFILING :=
--CCFLAGS := -Wall $(INC) $(CONFIG) -O2 -DNDEBUG $(PROFILING)
-+CCFLAGS := -fPIC -Wall $(INC) $(CONFIG) -O2 -DNDEBUG $(PROFILING)
- CXXFLAGS := $(CCFLAGS) $(CPP11_FLAGS)
- CCDFLAGS := -Wall $(INC) $(CONFIG) -ggdb
- CXXDFLAGS := $(CCDFLAGS)
-@@ -193,7 +193,7 @@ bin/off2obj: obj/off2obj.o
-
- obj/isct/triangle.o: src/isct/triangle.c
- @echo "Compiling the Triangle library"
-- @$(CC) -O2 -DNO_TIMER \
-+ @$(CC) $(CCFLAGS) -O2 -DNO_TIMER \
- -DREDUCED \
- -DCDT_ONLY -DTRILIBRARY \
- -Wall -DANSI_DECLARATORS \
-diff --git a/src/mesh/mesh.isct.tpp b/src/mesh/mesh.isct.tpp
-index a0acc15..69d33a8 100644
---- a/src/mesh/mesh.isct.tpp
-+++ b/src/mesh/mesh.isct.tpp
-@@ -650,14 +650,14 @@ public:
- // DGM: to replace lambda in IsctProblem constructor!
- void quantizeVerts(const Quantization& quantizer)
- {
-- if (!mesh)
-+ if (!TopoCache::mesh)
- return;
-
-- size_t N = mesh->verts.size();
-+ size_t N = TopoCache::mesh->verts.size();
- quantized_coords.resize(N);
-
- uint write = 0;
-- for (Vptr v = verts.getFirst(); v != NULL; v = verts.getNext(v))
-+ for (Vptr v = TopoCache::verts.getFirst(); v != NULL; v = TopoCache::verts.getNext(v))
- {
- #ifdef _WIN32
- Vec3d raw = mesh->verts[v->ref].pos;
-@@ -1106,7 +1106,7 @@ void Mesh<VertData,TriData>::IsctProblem::findIntersections()
- if(nTrys <= 0) {
- CORK_ERROR("Ran out of tries to perturb the mesh");
- //std::logic_error
-- throw std::exception("Ran out of tries to perturb the mesh");
-+ throw std::runtime_error("Ran out of tries to perturb the mesh");
- //exit(1);
- }
-
-diff --git a/src/util/prelude.h b/src/util/prelude.h
-index 6836ace..6981d20 100644
---- a/src/util/prelude.h
-+++ b/src/util/prelude.h
-@@ -60,7 +60,7 @@ std::ostream &err();
- err() << "ENSURE FAILED at " \
- << __FILE__ << ", line #" << __LINE__ << ":\n" \
- << " " << #STATEMENT << std::endl; \
-- throw std::exception("ENSURE FAILED"); \
-+ throw std::runtime_error("ENSURE FAILED"); \
- } \
- }
- #endif // ENSURE