summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca2021-03-11 10:42:11 +0100
committerLuca2021-03-11 10:42:11 +0100
commit96b0aaa38c05acb14d2ae9ef0d48b6db760ed000 (patch)
treebbaa2eaa3c84ae2494f05a39d5b02ec99307517f
parenteb1c8d2c2b2463d8fdd13cfd164a816884170119 (diff)
downloadaur-96b0aaa38c05acb14d2ae9ef0d48b6db760ed000.tar.gz
updated to match latest changes in CC sources - removed DLIB, which is now shipped
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2cbb9880add4..261df3cb6beb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,13 @@ name=cloudcompare
#_fragment="#branch="
options=('!strip') # strip would also remove plugins, for some reason
pkgname=${name}-git
-pkgver=2.10.2.r907.g2a4dd249
+pkgver=2.10.2.r912.g39679fc6
pkgrel=1
pkgdesc="A 3D point cloud (and triangular mesh) processing software"
arch=('i686' 'x86_64')
url="http://www.danielgm.net/cc/"
license=('GPL2')
-depends=('cgal' 'dlib' 'fbx-sdk' 'ffmpeg' 'glew' 'glu' 'mesa' 'mpir' 'pdal' 'qt5-base' 'qt5-tools' 'qt5-svg' 'shapelib' 'tbb' 'vxl' 'opencascade' 'gdal')
+depends=('cgal' 'fbx-sdk' 'ffmpeg' 'glew' 'glu' 'mesa' 'mpir' 'pdal' 'qt5-base' 'qt5-tools' 'qt5-svg' 'shapelib' 'tbb' 'vxl' 'opencascade' 'gdal')
makedepends=('clang' 'cmake' 'doxygen' 'git' 'laz-perf' 'libharu' 'ninja' 'pcl' 'proj' 'python')
optdepends=('pcl')
conflicts=('cloudcompare')
@@ -70,8 +70,7 @@ build() {
-DPLUGIN_IO_QSTEP=ON # requires opencascade
-DOPENCASCADE_INC_DIR="/usr/include/opencascade"
-DOPENCASCADE_LIB_DIR="/usr/lib"
- -DPLUGIN_STANDARD_QCANUPO:BOOL=ON # requires dlib
- -DDLIB_ROOT:PATH="/usr" # required by qcanupo plugin
+ -DPLUGIN_STANDARD_QCANUPO:BOOL=ON
-DPLUGIN_STANDARD_QCOMPASS:BOOL=ON
-DPLUGIN_STANDARD_QCORK:BOOL=ON # require mpir, cork (cork-git is not enough)
-DMPIR_INCLUDE_DIR:PATH=/usr/include # required by qcork plugin