summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2022-07-02 18:14:08 +0200
committerbartus2022-07-02 18:14:08 +0200
commitdc74373d5cd51839c8c893544b8d87b016929227 (patch)
tree609a422fa8ad4effb587789c20727f81a4b71c93
parentc2ff9489de78e6acd0fde0fd50860a2c4250857c (diff)
downloadaur-dc74373d5cd51839c8c893544b8d87b016929227.tar.gz
Add config env vars
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0eb405c3027e..e99ff44148a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -37,7 +37,7 @@ pkgbase = cloudcompare-git
provides = cloudcompare
conflicts = cloudcompare
options = !strip
- source = cloudcompare::git+https://github.com/CloudCompare/CloudCompare.git
+ source = cloudcompare::git+https://github.com/CloudCompare/CloudCompare.git#branch=master
source = cloudcompare-cork::git+https://github.com/CloudCompare/cork.git
source = CloudCompare.desktop
source = ccViewer.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 2b11ee97c7b8..2c6ade7e50d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,6 +4,11 @@
# Contributor : Danilo Bargen <aur at dbrgn dot ch>
# shellcheck disable=SC2034,SC2154 # allow unused/uninitialized variables.
+## Configuration env vars:
+_fragment=#${FRAGMENT:-branch=master}
+# Use CMAKE_FLAGS=xxx:yyy:zzz to define extra CMake flags
+[[ -v CMAKE_FLAGS ]] && mapfile -t -d: CMAKE_FLAGS < <(echo -n "$CMAKE_FLAGS")
+
name=cloudcompare
#_fragment="#branch="
options=('!strip') # strip would also remove plugins, for some reason
@@ -56,7 +61,7 @@ prepare() {
build() {
export CCACHE_BASEDIR="$srcdir"
# shellcheck disable=SC2191
- CMAKE_FLAGS=(
+ CMAKE_FLAGS+=(
-Wno-dev
-DPCL_QHULL_REQUIRED_TYPE=SHARED
-DCMAKE_CXX_STANDARD=14