summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorluca from muntzer2021-03-09 14:44:17 +0100
committerluca from muntzer2021-03-09 14:44:17 +0100
commiteb1c8d2c2b2463d8fdd13cfd164a816884170119 (patch)
tree52df3153578b0a4045f734fffb65152620af5f51
parentbd0f4bbeda44abe9f43332c1c71cc220278bd271 (diff)
downloadaur-eb1c8d2c2b2463d8fdd13cfd164a816884170119.tar.gz
also enable latest plugins
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7fda15fbfb36..2cbb9880add4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ name=cloudcompare
#_fragment="#branch="
options=('!strip') # strip would also remove plugins, for some reason
pkgname=${name}-git
-pkgver=2.10.2.r906.gb55fa745
+pkgver=2.10.2.r907.g2a4dd249
pkgrel=1
pkgdesc="A 3D point cloud (and triangular mesh) processing software"
arch=('i686' 'x86_64')
@@ -94,13 +94,14 @@ build() {
-DPLUGIN_STANDARD_MASONRY_QAUTO_SEG=ON
-DPLUGIN_STANDARD_MASONRY_QMANUAL_SEG=ON
-DPLUGIN_STANDARD_QANIMATION=ON
+ -DQANIMATION_WITH_FFMPEG_SUPPORT=ON
-DPLUGIN_STANDARD_QBROOM=ON
-DPLUGIN_STANDARD_QCANUPO=ON
- -DPLUGIN_STANDARD_QCOLORIMETRIC_SEGMENTER=OFF # giving troubles with wrong return type
+ -DPLUGIN_STANDARD_QCOLORIMETRIC_SEGMENTER=ON
-DPLUGIN_STANDARD_QJSONRPC=ON
- -DPLUGIN_STANDARD_QMPLANE=OFF # truoubles due to missing import
+ -DPLUGIN_STANDARD_QMPLANE=ON
-DEIGEN_ROOT_DIR=/usr/include/eigen3
- -DCMAKE_CXX_COMPILER=/usr/bin/clang++
+ -DCMAKE_CXX_COMPILER=/usr/bin/clang++ # using clang, which is needed to compile with cgal
)