summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-07 14:43:00 -0500
committerCarlos Aznarán Laos2023-05-07 14:43:00 -0500
commitd15dfa9a4bd30d4685fd2903d3f5af95405ef1c5 (patch)
tree640b5773da331f5b5bdfc409a76b50f6b7c5c42d
parent9ca936549004b6a7f9f3efe615b4f2547ca0e789 (diff)
downloadaur-cmakew.tar.gz
Python 3.11 rebuild
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d943fb613aa9..653e0c1dcf16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,8 @@ pkgbase = cmakew
url = https://github.com/thombashi/cmakew
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index d241b6cbdbd8..13f68b47e3b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,23 +8,19 @@ arch=('any')
url="https://github.com/thombashi/${pkgname}"
license=(MIT)
depends=(python-logbook python-subprocrunner python-typepy) # python-six
-makedepends=(python-setuptools python-wheel git)
+makedepends=(python-build python-installer python-setuptools python-wheel git)
source=("${pkgname}-${pkgver}::git+${url}.git?signed#tag=v${pkgver}")
validpgpkeys=('ACEC3954F31619D7288C17B07BAC46763C91BB7A') # Tsuyoshi Hombashi <tsuyoshi.hombashi@gmail.com>
sha512sums=('SKIP')
build() {
cd ${pkgname}-${pkgver}
- python setup.py build
-}
-
-check() {
- cd ${pkgname}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd ${pkgname}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dvm644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dvm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}