summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbinex-dsk2020-07-14 22:11:54 -0400
committerbinex-dsk2020-07-14 22:11:54 -0400
commit2cbda939551c2156e674befdeb2ce80b57ef3be2 (patch)
tree98408f3ab140186f432c9a049fb92a3ce36954ad
parent81b0a3e3b3b8a5fcf2d98352561c1b4cd8c59881 (diff)
downloadaur-2cbda939551c2156e674befdeb2ce80b57ef3be2.tar.gz
screw it, just grabs from the url now
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6cdbd3913032..93785bd2181b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = cmdtools-git
pkgdesc = Tools to manipulate, create, and view commands.
- pkgver = 1.0.0
+ pkgver = 1.0.0.r4.gc85fe99
pkgrel = 1
url = https://github.com/binex-dsk/cmdtools
arch = any
license = GPL3
- depends = shc
- source = 1.0.0.tar.gz::https://github.com/binex-dsk/cmdtools/archive/1.0.0.tar.gz
- md5sums = ff7a69ed5fc64db79bc1a466946d96f2
+ source = git+https://github.com/binex-dsk/cmdtools.git
+ md5sums = SKIP
pkgname = cmdtools-git
diff --git a/PKGBUILD b/PKGBUILD
index 0316bcc512ab..87033ec350d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Carson Rueter <bottomtext97@gmail.com>
pkgname='cmdtools-git'
reponame='cmdtools'
-pkgver=1.0.0
+pkgver=1.0.0.r4.gc85fe99
pkgrel=1
pkgdesc="Tools to manipulate, create, and view commands."
arch=('any')
url="https://github.com/binex-dsk/cmdtools"
license=('GPL3')
-source=("${pkgver}.tar.gz::https://github.com/binex-dsk/${reponame}/archive/${pkgver}.tar.gz")
-depends=('shc')
-md5sums=('ff7a69ed5fc64db79bc1a466946d96f2')
+source=("git+https://github.com/binex-dsk/cmdtools.git")
+md5sums=('SKIP')
pkgver() {
- git clone "${url}.git"
- cd $reponame
+ cd $srcdir/$reponame
git describe --tags | sed 's/-/.r/;s/-/./'
}
package() {
- for i in `ls src`; do
- install -Dm755 "$i" "${pkgdir}/usr/bin/$i"
+ for i in `ls $srcdir/$reponame/src`; do
+ echo $i
+ install -Dm755 "$srcdir/$reponame/src/$i" "${pkgdir}/usr/bin/$i"
done
}