summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspergmoment2020-07-06 15:41:54 -0400
committerspergmoment2020-07-06 15:41:54 -0400
commit6640fc18e4a98336690088d712fb3a4d9aae35f7 (patch)
treeee301a5b90ff4744003cb29870f0c953985fd7b4
downloadaur-6640fc18e4a98336690088d712fb3a4d9aae35f7.tar.gz
first push, thingy idk
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f07bb87ab72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = cmdtools-git
+ pkgdesc = Tools to manipulate, create, and view commands.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/binex-dsk/cmdtools
+ arch = any
+ license = GPL3
+ depends = shc
+ source = src-1.0.0::https://github.com/binex-dsk/cmdtools/releases/download/1.0.0/src-1.0.0.tar.gz
+ md5sums = ff7a69ed5fc64db79bc1a466946d96f2
+
+pkgname = cmdtools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b06411ff2f9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Carson Rueter <bottomtext97@gmail.com>
+pkgname='cmdtools-git'
+reponame='cmdtools'
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Tools to manipulate, create, and view commands."
+arch=('any')
+url="https://github.com/binex-dsk/cmdtools"
+license=('GPL3')
+source=("src-${pkgver}::https://github.com/binex-dsk/${reponame}/releases/download/${pkgver}/src-${pkgver}.tar.gz")
+depends=('shc')
+md5sums=('ff7a69ed5fc64db79bc1a466946d96f2')
+
+pkgver() {
+ git clone "${url}.git"
+ cd "$reponame"
+ git describe --tags | sed 's/-/.r/;s/-/./'
+}
+
+package() {
+ for i in `ls *cmd`; do
+ shc -f "$i" -o "$i.comp"
+ install -Dm755 "$i.comp" "${pkgdir}/usr/bin/$i"
+ done
+}