summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbinex-dsk2020-07-14 21:49:10 -0400
committerbinex-dsk2020-07-14 21:49:10 -0400
commit81b0a3e3b3b8a5fcf2d98352561c1b4cd8c59881 (patch)
treec1a233c0d626e57da45dd27918d4b5414e710e4a
parent8e8faf4359ddeb38eb4cdfb2a840ecbe6181e563 (diff)
downloadaur-81b0a3e3b3b8a5fcf2d98352561c1b4cd8c59881.tar.gz
apparently it works with makepkg but not yay
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f07bb87ab72..6cdbd3913032 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = cmdtools-git
arch = any
license = GPL3
depends = shc
- source = src-1.0.0::https://github.com/binex-dsk/cmdtools/releases/download/1.0.0/src-1.0.0.tar.gz
+ source = 1.0.0.tar.gz::https://github.com/binex-dsk/cmdtools/archive/1.0.0.tar.gz
md5sums = ff7a69ed5fc64db79bc1a466946d96f2
pkgname = cmdtools-git
diff --git a/PKGBUILD b/PKGBUILD
index a2b3c0b5890a..0316bcc512ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,19 +7,18 @@ pkgdesc="Tools to manipulate, create, and view commands."
arch=('any')
url="https://github.com/binex-dsk/cmdtools"
license=('GPL3')
-source=("src-${pkgver}::https://github.com/binex-dsk/${reponame}/releases/download/${pkgver}/src-${pkgver}.tar.gz")
+source=("${pkgver}.tar.gz::https://github.com/binex-dsk/${reponame}/archive/${pkgver}.tar.gz")
depends=('shc')
md5sums=('ff7a69ed5fc64db79bc1a466946d96f2')
pkgver() {
- git clone "${url}.git" getver
- cd "getver"
+ git clone "${url}.git"
+ cd $reponame
git describe --tags | sed 's/-/.r/;s/-/./'
}
package() {
- for i in `ls *cmd`; do
- shc -f "$i" -o "$i.comp"
- install -Dm755 "$i.comp" "${pkgdir}/usr/bin/$i"
+ for i in `ls src`; do
+ install -Dm755 "$i" "${pkgdir}/usr/bin/$i"
done
}