summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbinex-dsk2020-07-14 21:45:58 -0400
committerbinex-dsk2020-07-14 21:45:58 -0400
commitbd5c9ed87bcb8e6751b8122fc6803e392d41038e (patch)
tree26553968a1b6427aff96a85280a3621e3116effc
parent8e8faf4359ddeb38eb4cdfb2a840ecbe6181e563 (diff)
downloadaur-bd5c9ed87bcb8e6751b8122fc6803e392d41038e.tar.gz
nvm, this should fix it
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f07bb87ab72..564c02ca5bd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = cmdtools-git
pkgdesc = Tools to manipulate, create, and view commands.
- pkgver = 1.0.0
+ pkgver = 1.0.0.r4.gc85fe99
pkgrel = 1
url = https://github.com/binex-dsk/cmdtools
arch = any
license = GPL3
depends = shc
- source = src-1.0.0::https://github.com/binex-dsk/cmdtools/releases/download/1.0.0/src-1.0.0.tar.gz
+ source = 1.0.0.r4.gc85fe99.tar.gz::https://github.com/binex-dsk/cmdtools/archive/1.0.0.r4.gc85fe99.tar.gz
md5sums = ff7a69ed5fc64db79bc1a466946d96f2
pkgname = cmdtools-git
diff --git a/PKGBUILD b/PKGBUILD
index a2b3c0b5890a..96d87cac8636 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
# Maintainer: Carson Rueter <bottomtext97@gmail.com>
pkgname='cmdtools-git'
reponame='cmdtools'
-pkgver=1.0.0
+pkgver=1.0.0.r4.gc85fe99
pkgrel=1
pkgdesc="Tools to manipulate, create, and view commands."
arch=('any')
url="https://github.com/binex-dsk/cmdtools"
license=('GPL3')
-source=("src-${pkgver}::https://github.com/binex-dsk/${reponame}/releases/download/${pkgver}/src-${pkgver}.tar.gz")
+source=("${pkgver}.tar.gz::https://github.com/binex-dsk/${reponame}/archive/${pkgver}.tar.gz")
depends=('shc')
md5sums=('ff7a69ed5fc64db79bc1a466946d96f2')
pkgver() {
- git clone "${url}.git" getver
- cd "getver"
+ git clone "${url}.git"
+ cd $reponame
git describe --tags | sed 's/-/.r/;s/-/./'
}
package() {
- for i in `ls *cmd`; do
- shc -f "$i" -o "$i.comp"
- install -Dm755 "$i.comp" "${pkgdir}/usr/bin/$i"
+ for i in `ls src`; do
+ install -Dm755 "$i" "${pkgdir}/usr/bin/$i"
done
}