summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKamran Mackey2020-06-02 00:34:42 -0600
committerKamran Mackey2020-06-02 00:34:42 -0600
commiteba90627d95c9f75f517a10bf9e7349194d4bb36 (patch)
tree36f84c08426a11e7ebfbc03df5d21269a704182f
parent40f8ed7dd128b4e003602dda700c5b59993fa3fb (diff)
downloadaur-eba90627d95c9f75f517a10bf9e7349194d4bb36.tar.gz
Actually, swap back over to the official repository.
I don't know what the guidelines of the AUR are, but I don't want to risk having my privileges revoked for not sticking to official repositories. My personal take on using my personal repository originally was because the repository hasn't seen that much activity since January and the program has been in a light maintenance state for a while. I might consider creating an alternative cmus-git package though with my changes. Signed-off-by: Kamran Mackey <kamranm1200@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c33ab3938ae5..f2b36b2f959f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cmus-git
pkgdesc = Small, fast and powerful console music player for Unix-like operating systems.
- pkgver = v2.8.0.r45.g33fad6e
+ pkgver = v2.8.0.r24.gd1290d5
pkgrel = 1
url = https://cmus.github.io/
arch = x86_64
@@ -43,7 +43,7 @@ pkgbase = cmus-git
optdepends = wavpack: for wavpack input plugin support
provides = cmus
conflicts = cmus
- source = git://github.com/KamranMackey/cmus
+ source = git://github.com/cmus/cmus
sha512sums = SKIP
pkgname = cmus-git
diff --git a/PKGBUILD b/PKGBUILD
index 69b1f60795be..4b58e6366fb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kamran Mackey <kamranm1200@gmail.com>
pkgname=cmus-git
-pkgver=v2.8.0.r45.g33fad6e
+pkgver=v2.8.0.r24.gd1290d5
pkgrel=1
pkgdesc="Small, fast and powerful console music player for Unix-like operating systems."
arch=('x86_64' 'aarch64')
@@ -43,7 +43,7 @@ optdepends=('alsa-lib: for ALSA output plugin support'
conflicts=('cmus')
provides=('cmus')
license=('GPL')
-source=(git://github.com/KamranMackey/cmus)
+source=(git://github.com/cmus/cmus)
sha512sums=('SKIP')
_gitname=cmus
@@ -53,16 +53,14 @@ pkgver() {
}
build() {
- cd "$_gitname"/src/
- chmod +x configure
+ cd "$_gitname"
./configure prefix=/usr
make
}
package() {
- cd "$_gitname"/src/
+ cd "$_gitname"
make DESTDIR="$pkgdir" install
- cd ../
install -Dm644 contrib/cmus.bash-completion "$pkgdir"/usr/share/bash-completion/completions/cmus
install -Dm644 contrib/_cmus "$pkgdir"/usr/share/zsh/site-functions/_cmus
}