summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAl3xG2020-03-10 13:12:23 +0100
committerAl3xG2020-03-10 13:12:23 +0100
commit6ae59ca20f9b7c1e577c94723c9358508654cb3b (patch)
tree09c642d13dafa1db24358b26b57ac92710992f9a
downloadaur-cnijfilter-mx520series.tar.gz
first release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD45
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62b597fef285
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cnijfilter-mx520series
+ pkgdesc = Canon InkJet printer driver (MX520 series, binary)
+ pkgver = 3.90
+ pkgrel = 1
+ url = https://www.canon-europe.com/support/consumer_products/products/fax__multifunctionals/inkjet/pixma_mx_series/mx525.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = popt
+ optdepends = gtk2: Canon maintenance GUI support
+ provides = cnijfilter-common=3.90
+ conflicts = cnijfilter-common
+ source = http://gdlp01.c-wss.com/gds/5/0100005155/01/cnijfilter-mx520series-3.90-1-deb.tar.gz
+ md5sums = a58da1834d275590193cd91b018053fa
+
+pkgname = cnijfilter-mx520series
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..543721c9f1d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Contributor: Alessandro Guido <alexguido@gmail.com>
+
+pkgname=cnijfilter-mx520series
+pkgver=3.90
+pkgrel=1
+pkgdesc="Canon InkJet printer driver (MX520 series, binary)"
+arch=('i686' 'x86_64')
+url="https://www.canon-europe.com/support/consumer_products/products/fax__multifunctionals/inkjet/pixma_mx_series/mx525.html"
+license=('custom')
+depends=('popt')
+optdepends=('gtk2: Canon maintenance GUI support')
+provides=("cnijfilter-common=$pkgver")
+conflicts=("cnijfilter-common")
+source=(http://gdlp01.c-wss.com/gds/5/0100005155/01/cnijfilter-mx520series-$pkgver-1-deb.tar.gz)
+md5sums=('a58da1834d275590193cd91b018053fa')
+
+package() {
+ local _pkgarch=$(echo -n "${CARCH}" | sed 's/x86_/amd/' | sed 's/i6/i3/')
+ local _debdir="${srcdir}/cnijfilter-mx520series-${pkgver}-1-deb/packages"
+
+ cd $pkgdir
+ ar -x "${_debdir}/cnijfilter-common_${pkgver}-1_${_pkgarch}.deb" "data.tar.gz"
+ tar -xzf data.tar.gz && rm -f data.tar.gz
+
+ ar -x "${_debdir}/cnijfilter-mx520series_${pkgver}-1_${_pkgarch}.deb" \
+ "data.tar.gz"
+ tar -xzf data.tar.gz && rm -f data.tar.gz
+
+ mkdir -p usr/share/licenses/${pkgname}
+ mv usr/share/doc/cnijfilter-common/* usr/share/licenses/${pkgname}
+ rmdir usr/share/doc/cnijfilter-common
+ mv usr/share/doc/cnijfilter-mx520series/* usr/share/licenses/${pkgname}
+ rmdir usr/share/doc/cnijfilter-mx520series
+ rmdir usr/share/doc
+
+ # Weird permissions error from namcap
+ chown root usr/lib/bjlib/cnnet.ini
+ chgrp root usr/lib/bjlib/cnnet.ini
+
+ chmod 0755 $(find usr/bin -type f)
+ chmod 0755 $(find usr/lib -type f)
+ chmod 0644 $(find usr/share -type f)
+ chmod 0644 $(find etc -type f)
+}
+