summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIwan Timmer2015-12-08 20:02:25 +0100
committerIwan Timmer2015-12-08 20:02:25 +0100
commit767fceb4feb7c1b93a49708aca88d7af54d03454 (patch)
treefad1ffc02b93e606d028196c81f2dc1bebedfa8b
parent99233304ceab5144110f652e525ee1c1dec05bea (diff)
downloadaur-767fceb4feb7c1b93a49708aca88d7af54d03454.tar.gz
Update to version 0.86
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--remotectl-with-empty-selinux.patch25
3 files changed, 8 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54375a594cda..782d11e8e907 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cockpit
pkgdesc = A systemd web based user interface for Linux servers
- pkgver = 0.84
- pkgrel = 2
+ pkgver = 0.86
+ pkgrel = 1
url = http://www.cockpit-project.org/
arch = i686
arch = x86_64
@@ -31,10 +31,8 @@ pkgbase = cockpit
optdepends = udisks2
optdepends = networkmanager
conflicts = cockpit-git
- source = https://github.com/cockpit-project/cockpit/archive/0.84.tar.gz
- source = remotectl-with-empty-selinux.patch
- sha1sums = 55ab248fa174f1bd16c8d77cf704e33ebc4b1e5d
- sha1sums = c18aae424cd724178bbd0502b9aae17e15f861f8
+ source = https://github.com/cockpit-project/cockpit/archive/0.86.tar.gz
+ sha1sums = 49226f40e6d869f6107b1a31e75685ac0af59fc4
pkgname = cockpit
diff --git a/PKGBUILD b/PKGBUILD
index a13913dfaba0..d53be11baeba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
pkgname=cockpit
-pkgver=0.84
-pkgrel=2
+pkgver=0.86
+pkgrel=1
pkgdesc='A systemd web based user interface for Linux servers'
arch=(i686 x86_64 armv6h armv7h)
url='http://www.cockpit-project.org/'
@@ -13,15 +13,8 @@ conflicts=(cockpit-git)
depends=(libssh krb5 sshpass accountsservice perl-json perl-locale-po json-glib pcp glib-networking)
makedepends=(git intltool python2-pyscss gtk-doc perl-javascript-minifier-xs gobject-introspection networkmanager libgsystem xmlto npm)
optdepends=(storaged udisks2 networkmanager)
-source=(https://github.com/cockpit-project/cockpit/archive/${pkgver}.tar.gz
- remotectl-with-empty-selinux.patch)
-sha1sums=('55ab248fa174f1bd16c8d77cf704e33ebc4b1e5d'
- 'c18aae424cd724178bbd0502b9aae17e15f861f8')
-
-prepare() {
- cd "${srcdir}"/${pkgname}-${pkgver}
- patch -Np1 -i ../remotectl-with-empty-selinux.patch
-}
+source=(https://github.com/cockpit-project/cockpit/archive/${pkgver}.tar.gz)
+sha1sums=('49226f40e6d869f6107b1a31e75685ac0af59fc4')
build() {
cd cockpit-${pkgver}
diff --git a/remotectl-with-empty-selinux.patch b/remotectl-with-empty-selinux.patch
deleted file mode 100644
index 53e6eaa24a0d..000000000000
--- a/remotectl-with-empty-selinux.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 6246c16d0bed3ce63f3b598684849823d8661282 Mon Sep 17 00:00:00 2001
-From: Stef Walter <stefw@redhat.com>
-Date: Thu, 19 Nov 2015 12:24:25 +0100
-Subject: [PATCH] remotectl: Don't try to run chcon with an empty SELinux
- context
-
-Closes #3186
-Reviewed-by: Peter <petervo@redhat.com>
----
- src/remotectl/certificate.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/remotectl/certificate.c b/src/remotectl/certificate.c
-index 9aacac9..45d5c15 100644
---- a/src/remotectl/certificate.c
-+++ b/src/remotectl/certificate.c
-@@ -128,6 +128,8 @@ ensure_certificate (const gchar *user,
- goto out;
- }
-
-+ if (g_strcmp0 (selinux, "") == 0)
-+ selinux = NULL;
- if (selinux)
- {
- chcon_argv[3] = path;