summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhe Park2024-05-07 15:33:51 +0800
committerSainnhe Park2024-05-07 15:33:51 +0800
commit6d1ff8db9a788e66a1548dc096b937bedfe0b190 (patch)
tree53a1cd0fc56453bcb917b6587ebf8101192253bf
parent2eeb30177263ac35d408b615d6faac900591eade (diff)
downloadaur-code-features.tar.gz
Update to 1.89.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--patch.json30
3 files changed, 20 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dce567529127..20e987d84f0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = code-features
pkgdesc = Unblock some features in Code OSS
- pkgver = 1.88.0
+ pkgver = 1.89.0
pkgrel = 1
url = https://github.com/microsoft/vscode
install = code-features.install
@@ -17,6 +17,6 @@ pkgbase = code-features
source = patch.json
md5sums = 1d4002cba0560dd6da192ddd756f52e5
md5sums = 9ed6f3972479ab6d3d053e7c47ead55a
- md5sums = 3825c66c686454d02425c8b265f0d499
+ md5sums = a3e5dd7d92cff2eaba9c129309ea4faa
pkgname = code-features
diff --git a/PKGBUILD b/PKGBUILD
index 42a36b644509..fbaeeff5c971 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Sainnhe Park <sainnhe@gmail.com>
pkgname=code-features
-pkgver=1.88.0
+pkgver=1.89.0
pkgrel=1
pkgdesc='Unblock some features in Code OSS'
arch=('any')
@@ -16,7 +16,7 @@ source=("${pkgname}.hook"
'patch.json')
md5sums=('1d4002cba0560dd6da192ddd756f52e5'
'9ed6f3972479ab6d3d053e7c47ead55a'
- '3825c66c686454d02425c8b265f0d499')
+ 'a3e5dd7d92cff2eaba9c129309ea4faa')
package() {
install -Dm 644 "${srcdir}/${pkgname}.hook" "${pkgdir}/usr/share/libalpm/hooks/${pkgname}.hook"
diff --git a/patch.json b/patch.json
index 2e33be43fca8..522a07251a08 100644
--- a/patch.json
+++ b/patch.json
@@ -327,12 +327,12 @@
"contribEditorContentMenu",
"quickPickSortByLabel",
"portsAttributes",
- "handleIssueUri",
"testObserver",
"quickPickItemTooltip",
"terminalDataWriteEvent",
"terminalExecuteCommandEvent",
- "contribIssueReporter"
+ "contribIssueReporter",
+ "terminalShellIntegration"
],
"ms-dotnettools.dotnet-interactive-vscode": [
"notebookMessaging"
@@ -422,23 +422,25 @@
],
"GitHub.vscode-pull-request-github": [
"activeComment",
+ "codiconDecoration",
+ "codeActionRanges",
"commentingRangeHint",
+ "commentReactor",
"commentThreadApplicability",
+ "contribAccessibilityHelpContent",
+ "contribCommentEditorActionsMenu",
+ "contribCommentPeekContext",
"contribCommentThreadAdditionalMenu",
"contribCommentsViewThreadMenus",
- "tokenInformation",
- "codeActionRanges",
- "commentReactor",
+ "contribEditorContentMenu",
"contribShareMenu",
- "fileComments",
- "contribCommentPeekContext",
- "codiconDecoration",
"diffCommand",
- "contribCommentEditorActionsMenu",
- "treeViewMarkdownMessage",
- "tabInputTextMerge",
+ "fileComments",
+ "quickDiffProvider",
"shareProvider",
- "quickDiffProvider"
+ "tabInputTextMerge",
+ "tokenInformation",
+ "treeViewMarkdownMessage"
],
"GitHub.copilot": [
"inlineCompletionsAdditions"
@@ -447,7 +449,6 @@
"inlineCompletionsAdditions"
],
"GitHub.copilot-chat": [
- "handleIssueUri",
"interactive",
"terminalDataWriteEvent",
"terminalExecuteCommandEvent",
@@ -493,7 +494,8 @@
],
"ms-python.debugpy": [
"portsAttributes",
- "contribIssueReporter"
+ "contribIssueReporter",
+ "debugVisualization"
],
"ms-toolsai.jupyter-renderers": [
"contribNotebookStaticPreloads"