summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUffe Jakobsen2023-10-24 14:57:49 +0200
committerUffe Jakobsen2023-10-24 14:57:49 +0200
commit1c2e58aac6c249ece9b5514306df972a95211a37 (patch)
tree783564efb3337223cad1cb6437c30e5270000466
parentfba1f920d417bb43dfdceebb0a7c219cb967a4a0 (diff)
downloadaur-1c2e58aac6c249ece9b5514306df972a95211a37.tar.gz
clean up - remove NATIVEBOOK define - does not work anymore
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
-rw-r--r--codelite-fsw-symlink.patch14
3 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd42ff1a23f5..e370bd066271 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = codelite-git
pkgdesc = Cross platform IDE for C, C++, Rust, Python, PHP and Node.js written in C++
- pkgver = 17.6.0.r91.g00c907873
+ pkgver = 17.7.0.r26.g473b156f7
pkgrel = 1
url = https://codelite.org/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 78594940e925..f6c7d655218e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgname=codelite-git
_gitname=codelite
-pkgver=17.6.0.r91.g00c907873
+pkgver=17.7.0.r26.g473b156f7
pkgrel=1
pkgdesc="Cross platform IDE for C, C++, Rust, Python, PHP and Node.js written in C++"
arch=('i686' 'x86_64' 'aarch64')
@@ -82,6 +82,9 @@ pkgver() {
}
prepare() {
+ #cd "${srcdir}"
+ #git clone -b master --single-branch --depth 1 --recursive --shallow-submodules https://github.com/eranif/codelite.git ${_gitname};
+
cd "${srcdir}/${_gitname}"
git submodule update --init
@@ -107,27 +110,26 @@ build() {
WX_CONFIG="wx-config"
# generate
+ # -DWITH_NATIVEBOOK=1 \
cmake -G "Unix Makefiles" \
+ -S . \
+ -B "${BUILD_DIR}" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCL_PREFIX=/usr \
-DWITH_PCH=0 \
-DWITH_WX_CONFIG="${WX_CONFIG}" \
- -DWITH_NATIVEBOOK=1 \
-DENABLE_LLDB=1 \
-DWITH_MYSQL=0 \
- -B "${BUILD_DIR}" \
- -S .
+
# build
- #make -s -C "${BUILD_DIR}"
cmake --build "${BUILD_DIR}"
}
package() {
cd "${srcdir}/${_gitname}"
- #make -s -C "${BUILD_DIR}" -j1 DESTDIR="${pkgdir}" install
DESTDIR="${pkgdir}" cmake --install "${BUILD_DIR}"
install -m 644 -D "${srcdir}/${_gitname}/LICENSE" "${pkgdir}/usr/share/licenses/codelite/LICENSE"
diff --git a/codelite-fsw-symlink.patch b/codelite-fsw-symlink.patch
index f788c8f6143c..85be28a885a6 100644
--- a/codelite-fsw-symlink.patch
+++ b/codelite-fsw-symlink.patch
@@ -103,7 +103,7 @@ index a57949053..ff0f98eee 100644
Q.push_back(fullpath);
}
diff --git LiteEditor/mainbook.cpp LiteEditor/mainbook.cpp
-index 5afba765f..ff6e453f9 100644
+index cc879bb30..3b35969fc 100644
--- LiteEditor/mainbook.cpp
+++ LiteEditor/mainbook.cpp
@@ -469,7 +469,7 @@ int MainBook::FindEditorIndexByFullPath(const wxString& fullpath)
@@ -138,7 +138,7 @@ index 5afba765f..ff6e453f9 100644
fileName.MakeAbsolute();
#ifdef __WXMSW__
-@@ -1844,7 +1851,7 @@ WelcomePage* MainBook::GetWelcomePage(bool createIfMissing)
+@@ -1845,7 +1852,7 @@ WelcomePage* MainBook::GetWelcomePage(bool createIfMissing)
clEditor* MainBook::OpenFileAsync(const wxString& file_name, std::function<void(IEditor*)>&& callback)
{
@@ -147,7 +147,7 @@ index 5afba765f..ff6e453f9 100644
auto editor = FindEditor(real_path);
if(editor) {
push_callback(std::move(callback), real_path);
-@@ -1855,7 +1862,7 @@ clEditor* MainBook::OpenFileAsync(const wxString& file_name, std::function<void(
+@@ -1856,7 +1863,7 @@ clEditor* MainBook::OpenFileAsync(const wxString& file_name, std::function<void(
m_book->SetSelection(index);
}
} else {
@@ -156,7 +156,7 @@ index 5afba765f..ff6e453f9 100644
if(editor) {
push_callback(std::move(callback), real_path);
}
-@@ -1914,7 +1921,7 @@ void MainBook::OnIdle(wxIdleEvent& event)
+@@ -1915,7 +1922,7 @@ void MainBook::OnIdle(wxIdleEvent& event)
auto editor = GetActiveEditor(false);
CHECK_PTR_RET(editor);
@@ -166,7 +166,7 @@ index 5afba765f..ff6e453f9 100644
void MainBook::OnEditorModified(clCommandEvent& event)
diff --git Plugin/globals.cpp Plugin/globals.cpp
-index 3ca9bfc33..a403a607b 100644
+index 024f7479c..324acc401 100644
--- Plugin/globals.cpp
+++ Plugin/globals.cpp
@@ -1094,7 +1094,7 @@ wxFileName wxReadLink(const wxFileName& filename)
@@ -196,10 +196,10 @@ index 3ca9bfc33..a403a607b 100644
int wxStringToInt(const wxString& str, int defval, int minval, int maxval)
diff --git Plugin/globals.h Plugin/globals.h
-index 343269561..1480bb546 100644
+index af285fdc6..6cdf761f0 100644
--- Plugin/globals.h
+++ Plugin/globals.h
-@@ -379,7 +379,7 @@ WXDLLIMPEXP_SDK wxFileName wxReadLink(const wxFileName& filename);
+@@ -373,7 +373,7 @@ WXDLLIMPEXP_SDK wxFileName wxReadLink(const wxFileName& filename);
/**
* @brief makes-absolute filepath, and dereferences it and any symlinked dirs in the path
*/